Fairphone 4 unlocking bootloader stuck

Hi everybody,

I tried to unlock the bootloader on my Fairphone 4. I followed this guide from the fairphone support website.
Unfortunately, I got stuck in the process and now I am not sure, if there is a problem.

I managed to unlock OEM and turned on USB debugging. Then I successfully run the command ADB reboot bootloader and fastboot flashing unlock and unlocked the bootloader via the dialog on the Fairphone screen.

user@computer platform-tools % ./ADB reboot bootloader

user@computer platform-tools % ./fastboot flashing unlock

OKAY [ 0.035s]

Finished. Total time: 0.036s

So far so good. Then I tried to repeat the steps for the command ./fastboot flashing unlock_critical, but I could not even get so far, because when the fairphone rebooted (automatically) after the first unlock my computer opened automatically the android file transfer app (god knows why). Maybe this is the source of all evil. Then I temporarily moved this app into trash such that this app cannot intervene.
However I always got the message:

user@computer platform-tools % ./ADB reboot bootloader

error: no devices/emulators found

Up to this point the phone booted normally into the welcome dialog of the original FairphoneOS, where I could have set up the phone.
I tried to use the alternative method

Unlock your bootloader
2. Alternatively, you can disconnect the USB cable, turn off your Fairphone, then connect the cable and hold the volume down button. After a few seconds, you’ll see the fastboot mode

which also didn’t do anything. Then because of confusion I selected Boot to FFBM, which I though might be Fairphone FastBoot Mode. After that the phone stuck in the boot state. On the screen there are only the four blue balls moving (start screen) and it is stuck in this state.

Then I repeated the alternative step 2 and ran the command fastboot flashing unlock_critical

user@computer platform-tools % ./fastboot flashing unlock_critical

OKAY [ 0.042s]

Finished. Total time: 0.044s

Now the phone boots normally again. I am not sure if I have succeeded. Maybe someone can tell me, if I broke something.

Best regards,


1 Like

Yes, I think you’ve succeeded and you can setup your system.

Yes, this sounds strange as at that point the phone should have been factory reset and have started into initial setup.

What did you expect the phone to do at that point? It was in Fastboot mode waiting for you to send a Fastboot command (e.g. the fastboot flashing unlock_critical).

1 Like

I am unsure what the FastBoot Mode is. In the following picture you see what happens after I started the phone by plug in the usb cable and hold volume down. With the volume buttons I can change the top line (currently in the picture “Boot to FFBM”).
In this picture: Am I already in FastBoot Mode or do I have to press the Power button to execute Boot to FFBM?

This is the Fastboot mode.
From here you normally only use the selectable functions to boot the system, to start recovery mode or to shut down the system.
But the main point of this mode is that you’re able to flash your phone using a PC connected via USB cable. Or you can lock or unlock the bootloader also via attached PC.
Boot to FFBM is AFAIK never needed by a “common user” like us…


ah good to know. I finally managed to finish all steps in the manual of the installation of eOS. However, when I executed the last step locking the bootloader fastboot flashing lock, the phone restarted and told me it was corrupt. I was too slow to take a picture of this situation. The phone now boots always in FastBoot Mode even when I select Power off. Do you know what I can do now? After the step fastboot flashing lock_critical (next to last step), the phone was showing the eOS welcome screen. So it seemed to be really the last step that messed with the phone.

Is unlocking the bootloader again a good idea?

Yes, currently there seem to be problems with locking the bootloader. You’ll find topics about that here in the forum and in the /e/ forum.
So at the moment you won’t be able to relock the bootloader (and also I wouldn’t recommend it - it can hard bricked your FP4).


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.