Fairphone 4 Mic issues

Greetings, I’ve been having issues with two of the mics either not passing the native Fairphone test by being silent or the 3rd one giving feedback, I tried doing the test in safe mode and all three work fine, today I did a factory reset, and all three microphones passed the test, but now for no apparent reason I’m all back to square one, I have no idea what’s going on, all the settings seem fine, I’ve tried everything Fairphone have suggested and stuff I’ve seen on the interwebz but still not working, any ideas? Just to clarify, in the Fairphone audio test it’s the top mic that’s silent and the side one that either screams feedback or impregnable silence. Just tried filming and there’s no sound being recorded at all through the side mic
Edit, just tried in safe mode again, all three working, yet the side one doesn’t record at all whilst filming in the built in camera app, and only the bottom one works with the built in recording app. Most befuddled!

Have you tied disabling mic permissions for Google? It’s not a solution but a temporary fix which seems to work for some