Fairphone 4 "locked in fastboot mode"

Hello all,

I have installed my Fairphone 4 according to these instructions.
Unfortunately, the phone always restarted after that. I was able to go into recovery mode once from /e/ and do a wipe.

Now I can not do anything on the phone. I only get into the fastboot screen.

The message is “DEVICE STATE - locked”.
Whether I select “Restart bootloader” or “Recovery Mode”, it always reboots into this mode.

What can I do now?

The phone is just 10 days old. :frowning:


1 Like

Welcome to the forum :wave:
A bit more information would be helpful to get this fixed.

  • What was your starting point? Was your phone modified before?
  • Which instructions did you follow?
  • Did you see any error messages when you flashed your phone?

That just means your bootloader is locked again. If you followed the instructions provided by /e/, that is expected to happen:

Lock the device with the following command
  • fastboot flashing lock
  • Approve with Voume + then power


What happens if you select START? :thinking:

change active slot, that’s all

what do you mean exactly?

Yeah, that’s probably it, should have thought of that before writing an essay :man_facepalming:

$ fastboot getvar current-slot
current-slot: b
$ fastboot --set-active a

Or vice versa (if your current slot is a, change it to b).

1 Like

Then I get the following error message

Setting current slot to ‘b’ FAILED (remote: 'Slot Change is not allowed in Lock State
fastboot: error: Command failed

You need to unlock the bootloader again:

$ fastboot flashing unlock

Thank you, that was it. :+1:

I have now tested this again, but on startup the /e/ logo appears once and the phone reboots.
I can then only boot in recovery mode from /e/.

E: emulated failed to bind mount /mnt/staging/emulated/media/0 on /storage/emulated: No such file or directory

That sounds like something went wrong while the partitions got flashed.

Instead of trying to debug this, I would suggest just starting the whole installation again from the top.
Try to copy and paste those lines one by one, when you get to that step

3. Flash /e/ with the following commands:

fastboot flash bluetooth_a bluetooth.img
fastboot flash bluetooth_b bluetooth.img
fastboot flash devcfg_a devcfg.img
fastboot erase userdata
fastboot erase metadata

And look for any errors that might come up.

Yes, I have already done the installation twice.

I will try this again.

I have now run the installation again.
Once completely and also test only with the “b” variants, because the phone is in “b” mode.

The only thing that works is the /e/ recovery mode.

In recovery mode I get the following messages

E: Failed to bind mount /mnt/staging/emulated/media/0 to /storage/emulated: No such file or directory
E: recvmsg failed (No buffer space vailable)
E: Open failed: /metadata/ota: No such file or directory
E: Couldn´t mount Metadata
E: [libfs_mgr]Faile to find block devie for partition

Now it worked.

I have switched the phone to “a” mode.

fastboot --set-active=a

After that it worked.

Although I had to set up the phone twice.
Once after the “fastboot flashing lock_critical” and once after the “fastboot flashing lock”.


Thanks guys, the same problems with A/B and locked fastboot I also had. :face_with_raised_eyebrow:
On the pc nothing , on the laptop (win7) nothing, read a bit here and already it works on the pc :man_dancing:
Good job and thanks a lot :beers: :metal:

1 Like

Only as a note:
Those people to whom the “fastboot --set-active” and “fastboot flash unlock” commands yield to an error like “is not allowed in Lock State” should continue at this topic Trapped in fastboot mode with locked bootloader and corrupted /e/ OS .
Unfortunately there is no solution for this issue up to now.

1 Like

Only if they aren’t able to boot their phone normally.
If the phone is still bootable enabling OEM unlocking in Settings → System → Developer options is still enough to get that capability back.

1 Like

Ok, my statement refers to the title of this topic "Fairphone 4 locked in fastboot mode” (which means the OS and recovery is not bootable anymore) :wink:

Had the same issue driving me mad, tried everything including switching active from a to b and back again.

Finally got things working, I used IMG-e-0.21-r-20220123158735-stable-FP4.zip first but then switched to IMG-e-0.21-r-20220112156786-stable-FP4.zip . The older release now boots :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.