Fairphone 4 can't charge anymore

Hi,
I’ve had my Fairphone 4 for a year.

It had occasional charging issues, but it’s been +/- impossible to charge it for the last few days.

Before that it was often stuck under -5% of battery, and it was sometimes very hard to make it go above that, always stuck in “slow charging mode”

It was randomly starting to charge last week, but I haven’t been able to turn it on since yesterday, I don’t even see an icon, even though it’s been plugged all night.

I’ve tried multiple chargers/cables/power sources that works fine with my other devices(wall socket, usb hub, regular usb cable directly to a laptop…)I’ve tried rebooting when there is enough battery to turn it on.

The battery does not appear to be physically damaged.

I’ve tried to contact the support yesterday, but there are huge delays at the moment.

Should I buy a new battery?new usb C port spare part?something else? I want to avoid buying something unnecessary.

What can I do while waiting for a response from the support?

I’ve already searched the forums and google.

Thanks in advance

Edit: I’ve bought a brand new charger, still not working

Welcome to the Fairphone community.

Did you check the USB port for debris thoroughly? Sometimes there is a very dense and compressed piece of dust or something inside. You can try with a tooth pick for example to clean the port.

2 Likes

Hi, thanks, I just tried with a toothpick, but nothing seemed to be stuck, and it still doesn’t work

In the end, the support told me the USB-C port was probably dead, they sent me a replacement, it works again!

2 Likes

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.