Fairphone 4 and Android 12 Status Bar Icons

These are more of an irritation than a problem, but

  1. Does anyone know why, when the alarm is set, there is no Status Bar icon displayed? There was before Android 12! If I go into the pull-down Quick Settings menu then the icon appears, but it disappears again as soon as I exit the menu;

  2. Is there supposed to be a Status Bar icon for ‘Wi-fi Calling Enabled’ like there is for Samsung and Iphones? If so, it’s not shown on my phone.


Your second screenshot proofs the first question. There is no alarmclock icon in the status when the quick setting menu is not pulled down. I can confirm this and guess its a bug , at least I have the icon on my FP3 with Andrpid 13 (Iode OS).

However it also shows the wifi-calling icon (not wifi bar was questioned) which I also have, so in general they are still there.


Thanks for your responses.

  1. My phone just says ‘Android version 12, so presumably 12.0’ and I’m also using the Google Clock app, so as Yvmuell says, presumably a bug.

  2. Here is a screenshot showing ‘EE Wi-Fi Calling’ on, but no indication of this in the Status Bar.

Whats set under preferences?

And why do you and I still have the wifi calling icon even twice? I cant see many icons in the OPs screenshot and would expect wifi calling to be visible…
Still sure that might be an exolanation for other icons like alarm clock although I somehow doubt, because setting the phone to vibration the icon is only visible when the barvis pulled down, however setting it to silent I always see the icon and I guess the space used it the same

@pagan and is it still working even without icon or not?

Maybe this helps somehow

Yes, no problem with functionality for either the Google Clock alarm or Wi-fi Calling. It was only ever a problem with Status Bar icons.
Thanks for your input, guys.

As you can see there are nearly no icons in the OPs screenshot, so the wifi calling icon is not hidden by the notch.

And here you can see nearly no icons either and still no alarm clock, so this is either a bug or intentional under A12 (what I doubt)

Not saying you are wrong in general (space for icons limited because of the notch), however for this case here its just not the reason.

@pagan best you contact support

1 Like

Is this a bug or a “feature” of newer Android versions? Becaus this is also happening in my FP3 since I updated from Android 11 to Android 13 (in A11, as you say, the alarm icon was displayed always). It’s annoying.


Good news to everyone! I now found a setting allowing the vibrate mode to be displayed in all cases. Sound & vibrationsAlways show icon when in vibrate mode. Not sure there is a similar setting for alarm clock.


Would have never searched there…thanks.

Thank you :), i have never seen this A13 feature! Great :smiley:

I actually have no idea when this option appeared. But it is there, hey!

1 Like

I was trying to find the missing alarm clock icon too. Now I noticed that at least the default clock widget shows the alarm, if set. This may be a solution for some, here.

(Personally I use the Microsoft launcher and its clock widget. There, showing the alarm or not is a setting)