Fairphone 3 unable to turn on and web ticket not an option

Hi,

Posting here because I can’t use the online portal as my IMEI number on the label has rubbed off.

My Fairphone 3 turned off this morning and I’m unable to turn it back on.

It was at full charge this morning so it should not be a battery issue.

I have tried 2 different chargers and tried to charge from my PC, with and without my back cover. I am getting no charging light in any of these scenarios.

I have taken out the battery, sim card and SD card, left for 30 minutes and then plugged in and have still had no response from my phone.

The IMEI number on the label has rubbed off so I am unable to provide this information.

Can you help?

1 Like

Welcome to the Community Forum.

I cannot help right now with the actual issue, but as I’m not sure what label you meant, just mentioning: You can find the IMEI(s) both at the slim inside wall of the battery tray as well as on the back of the blue/cyan slipjacket of the original white box the Fairphone 3 came in.

P.S.: Not meaning to silence you here, keep this post active, it might still get replies from others. :slight_smile:

2 Likes

Thanks for the response!

It was the label on the inside wall of the battery tray that I was referring to sadly.

I am currently on the other side of the country from the box that the Fairphone came in so I can’t get the code that way.

1 Like

This is a post on the (seemingly) same problem that has gotten a lot of attention here recently (you might want to focus on final/3rd paragraph – “bending”):

1 Like

Unfortunately just bending the phone doesn’t seem to fix the situation if it is a problem with the PMI632 chip.

Would you happen to know if the charging LED is part of the core module or if it is part of the display module? The last troubleshooting step that I can think of (Aside from replacing the PMI632) is taking off the display and reapplying it.

I don’t know for sure what part includes the LED, but it’s definitely not the display module. My guess is the top module – see the photos in Step 7 here:

I took the phone apart last night and it does look like the LED is in the top module.

I really appreciate your help, cheers.