English

Fairphone 3 stuck on boot screen after clean re-installation of Fairphone OS

Hello,

After successfully backing up my data, I wanted to test /e/ OS on my Fairphone 3. I followed the official instructions for unlocking the bootloader then the official /e/ installation instructions which went without error and I successfully booted into /e/ OS.

After a while, I wanted to move back to the stock Fairphone OS. So, I followed the official Fairphone 3 instructions from here and here to re-flash the stock Fairphone OS from my GNU/Linux system. The exact file of the stock Fairphone OS I downloaded and flashed was FP3-REL-Q-3.A.0084-20210204.105300-user-fastbootimage.7z from this page’s link.

I successfully extracted the file and ran sudo ./FP3_flashall which showed some text output in my terminal all saying “OK”.

Once that was done, my Fairphone 3 automatically rebooted. Unfortunately, it gets stuck on the Fairphone boot screen:

I tried the following steps but none helped:

  1. I waited more than one hour and my Fairphone 3 would still be stuck on this boot screen. I tried hard rebooting the phone multiple times by holding down the power button or removing the battery but it still gets stuck at this screen.
  2. I re-flashed /e/ OS using its official instructions. It went without error but afterwards my Fairphone 3 would refuse to boot and wouldn’t even get to the /e/ OS boot screen. So I re-flashed the stock Fairphone OS again, but that took me back to the original problem of being stuck on the Fairphone boot screen above.
  3. I removed the battery and left it out overnight and tried all of the above and got the same results.

The last thing I tried was following the official Fairphone factory reset instructions, which got me to the screen with the “fallen Android robot” screen with the “no command message”:

Then, I held the power button plus the volume up button which got me into a recovery screen:

Next, I initiated a factory reset and let it wipe my data. It proceeded without errors.

However, when I try to reboot my Fairphone 3 it still gets stuck on the same Fairphone boot screen I showed above.

How do I troubleshoot and fix this problem so that I can successfully boot my phone into the OS?

Thank you!


P.S. Here are a few other observations:

  1. On the recovery screen with the blue, white and yellow text there is an option to “View recovery logs”. I took pictures of the complete logs into this gallery, but I don’t know how to intepret them.
  2. When I was first installing /e/ OS as described above, I accidentally started with the command fastboot flash boot boot.img instead of the correct fastboot flash boot_a boot.img. So, I simply ran fastboot flash boot_a boot.img again and after the rest of the steps successfully booted into /e/ OS. Don’t know if this makes any difference.
  3. I can still get to the fastboot/bootloader screen to flash the OS, but like I said above while both the stock Fairphone OS and /e/ OS appear to flash without errors, they both refuse to boot. BTW, there’s the fastboot screen that I can still reach:

So, once again:

How do I troubleshoot and fix this problem so that I can successfully boot my phone into the OS?

Thank you!

There was an issue with one of the downloads, please see.

The download has since been updated. See post 19 of the topic above :slight_smile:

6 Likes

Thanks @amoun, I see that the update only happened within the last few hours! OK I will try again with the updated file.

3 Likes

It worked! The new file I used to flash is named FP3-REL-Q-3.A.0084-20210204.105300-user-fastbootimage_r2.7z and now I can boot into the stock Fairphone OS. Thank you @amoun! :pray:t3:

4 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.