Fairphone 3 OS Manual Installation gets stuck and doesn't finish

I’m trying to follow this guide to re-install Fairphone OS on my Fairphone 3, which previously had Lineage OS installed.

I successfully unlocked the bootloader and booted into fastboot. But when I run the flash_fp3.command, it never finishes and just gets stuck here:

*** Fairphone 3 flashing script ***

INFO: The procedure will start soon. Please wait...
INFO: You are using macOS.
INFO: Validating the integrity of the package.
      This might take a while. Please wait...
INFO: Validation complete.
INFO: Looking for connected device(s)...
INFO: One Fairphone 3 in fastboot mode found (serial number: xxx).
Sending 'aboot_a' (1646 KB)                        OKAY [  0.070s]
Writing 'aboot_a'                                  OKAY [  0.028s]
Finished. Total time: 0.144s
Sending 'aboot_b' (1646 KB)                        OKAY [  0.060s]
Writing 'aboot_b'                                  OKAY [  0.028s]
Finished. Total time: 0.122s
Rebooting into bootloader                          OKAY [  0.006s]
Finished. Total time: 0.006s

What I tried:

  • Boot the phone, maybe it succeeded already? It didn’t…
  • Cancel and try again
  • Wait for 1h
  • Download and try the previous version
  • Inspect the command script to see if I can find the issue (couldn’t find any “rebooting into bootloader” line or similar)
  • Search this forum (didn’t find anything related)

None of this worked and now I’m out of ideas :cry: Any help would be very appreciated!

Sorry, can’t really help here (don’t know the “normal” flashing process for a PF3 as I don’t own one and didn’t take the time myself to check the flashing script).

That’s probably not surprising. This message is generated by the phone (and not the script). The according command in the flashing script should be something like fastboot reboot-bootloader or simlar…

1 Like

If the issue is that the phone doesn’t reboot into bootloader automatically, you can do this manually by keeping the power button pressed for about 15 seconds (which forces a reboot) and then keeping Volume - pressed while rebooting (which boots the phone into bootloader aka fastboot mode).

Any Windows or Linux computer in sight to try, by chance?

Another thing …

Does fastboot mode really display “DEVICE STATE - unlocked” for you?

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.