Fairphone 3 locked by previous owner- factory reset protection


I recently bought a fairphone off ebay. It was described as broken however I managed to get it working again by cleaning and slightly scratching the screen connector contacts. Sadly however although now it appears to be working perfectly it is linked to a previous owner’s google account which I don’t have the password to and so I can’t get past the factory reset protection which asks for the google account login. I’ve tried a factory reset as described here but it doesn’t remove the FRP: Factory reset (erase all data) – Support (fairphone.com)

I’ve contacted the ebay seller but they say the person they bought it from reported they had removed the account link to the phone and have no way of contacting them.

Does anyone know a way around this? I am not that tech savvy but I’m up for learning!

Thanks in advance.


There is no way around, a theft protection would not make any sense if there is a simple trick to disengage it.

Thanks for your reply. I doubt it is an easy thing to get around, for the obvious reasons you describe, however I suspect as with most phone locks there may be a way to bypass it and I was wondering if anyone knew how.

As far as I can see theft protection is also a helpful way of the tech companies making it very difficult for consumers to buy or use second hand tech. Not great for the circular economy and I’m disappointed that fairphone have adopted this given their business goals.

If you have tried the factory reset – as described in your link under the headline " Fairphone does not boot anymore." – in system recovery (i.e. more thorough) and not just in the Settings menu, you might want to contact Fairphone Support with the IMEI numbers you can find in the battery tray to find out if the device was reported as lost or stolen to Fairphone Support.

1 Like

Sadly that could be a found or stolen phone that the seller couldn’t wipe either, hence the stalemate.

Contacting Fairphone to find the original owner is not very practical as even if they have some details they don’t have permission to contact the original owner.

I’ve never had a google account so don’t know what to do.

If you got a second hand device, contact the person who gave or sold you the device, so they can remove their account from the phone.

That clearly isn’t an option.

Reset your phone using its buttons:
If you reset your phone using its buttons (Recovery mode), you’ll need to enter your PIN, password, or pattern. You’ll also see an option to use the Google Account that was on your phone before you reset it.
Help prevent others from using your device without permission - Android Help

The above implies you only need the PIN etc. and then choose not to use a Google account.

Have you tried

Fairphone does not boot anymore.

Failing that maybe ebay will refund your money?

Thanks, I have tried factory reset in system recovery and yeah still comes up looking for google login. Very frustrating

1 Like

Not at all in my opinion. If they original owner takes the correct steps to remove his ownership settings, there is no obstacle at all.

In Germany, there is a saying: “Wash me, but don’t get me wet”.
Theft protection either by the phone manufacturer or the operating system is a good way to help the customer, to keep his phone.

If you do that to reset the phone, you will not be able to use the phone anymore.
As the page you linked to clearly states:

Important: You can sign in with any Google Account previously added and synced to the phone as an account or user, but not as a guest. If you can’t give this information during setup, you won’t be able to use the phone at all after factory reset.

Therefore, my conclusion from this article is, that the protection in fact is really thorough.

I would go with @urs_lesse to check with Fairphone via the IMEI, if the device was reported lost or stolen.
If that’s the case, it might be an idea to report the seller to the police.
They might find out more.

1 Like

I dont understand anything about it, however always had the feeling “EDL/firehose” are strong tools and leaked for the FP3… Do some search here maybe, in case you are adventurous

1 Like

Chances are very slim but if this FP3 was running September 2021 security patch apparently a loop hole existed as here: https://www.youtube.com/watch?v=vRE0bzIe1ac

Sadly I tried this this morning. Clearly they have found this loophole as the first step no longer works.

If the bootloader is unlocked, you might be able to wipe it from fastboot. If the bootloader is locked, however, I would just return it and/or get Ebay involved to get your money back.

1 Like

Thanks for the advice. I sadly don’t know much about this, e.g. I have no idea to find out if my bootloader is locked. Is there any chance you could link me to somewhere I can learn about this? Thanks, Donald

You will ‘need’ to install ADB and Fast boot on a computer and connect to the phone via a IF Data able USB cable. Use a good cable.

For a simple ADB install you can read how I did it to remove some google apps.

and there’s a link below with details on the bootloader that are off this site

As already mentioned above there are more adventurous ways even if the bootloader is locked.

To verify if its locked start into fastboot/bootloader when device is turned off, pressing simultaneously power and vol-up (if this shows recovery instead you can boot from there into bootloader) buttons you should see a screen saying something like “device state locked/unlocked”

Only when you want to proceed you need adb/fastboot on your PC

1 Like

OK I have just tried with my FP3

  • Power OFF
  • Connect to PC with ADB/Fastboot installed
  • Open Terminal on PC
  • Hold Power Button and Volume Down until vibrates
  • Phone screen should show START menu > do nothing
  • In terminal on PC type fastboot oem device-info
  • Terminal should show similar to image below

Once you have got this far you can investigate the phone and your skills

All the best

You don’t need a PC terminal to check the bootloader lock state! Its possible this way and not needed to do it this way.

Screenshot from a FP4 it looks the same for an FP3
Might be I mixed up above Recovery and Fastboot, so just try both (vol-up 9e down plus power) till you see that screen


Sorry for delayed reply has been a very busy few weeks at work. I’ve now checked this and the bootloader is locked :frowning:

So sounds like I need to explore the more adventurous options described above?

Thanks again,

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.