Fairphone 3+ charges powerbank instead of vice versa

Help! My Fairphone 3+ with e/os and android 11 charges the powerbank instead of vice versa.

Hello and welcome to the forum. That’s weird. It sounds like the powerbank is detected as an OTG device, resulting in the phone providing power to the powerbank. Can you try a different port or a different cable?

1 Like

One cable didn’t work at all, two others didn’t change anything. The powerbank has two ports, changing the port didn’t help.
Shall I stop OTG on the phone somehow?

I suppose that both are USB-C and both support charging the powerbank? I don’t think it’s possible to disable OTG. The only solution I can think of is to use a cable without data wires (just +5V and GND) or get a USB data blocker.

1 Like

Which powerbank exactly are we talking about?

For charging the powerbank there is a single USB-B-port, then there are two USB-A-ports. The powerbank was an advertising gift, probably especially made for i-phones an mac (the original cables are mac- and i-phone-cables). It has no name, the quality seems to be good. I have no instructions. It has a push button, pressing it the powerbank shows four leds for some seconds, if it is fully charged. The same problem appeared with a similar powerbank borrowed from friends.

I doubt that it’s possible to charge the powerbank via a USB-A port. Why do you think that’s what’s happening? Isn’t it simply that it doesn’t do anything? But yeah, gadgets made for iPhone sometimes work very weirdly (if at all) with other devices. Can you try it with any other phone?

1 Like

For charging the powerbank there is an USB-B-port. It’s possible, that charging the phone from the powerbank doesn’t do anything, but anyway the phone lost 1 or 2 percents of energy within short time, when I connected it with the powerbank, thats why I think that it charges rather the powerbank then vice versa. Charging an i-phone worked.
I know that there was an USB-issue on some phones, see https://www.tutonaut.de/handy-laedt-nicht-ueber-usb-c-probiert-das-hier/ , but I can not find similar USB-settings on my FP3+ with android 11 and e/os.

The problem is solved. Not the phone, but the powerbank was the problem. When I press the button on the powerbank two times for at least two seconds and only after that plug in very quickly the cable into the phone (not every cable works!) it charges normally. So the powerbank is somehow tricky, the FP3+ on the other side works well.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.