Fairphone 3+, bootloop on empty battery solved, now only charges when turned off

Hello everyone,
I have here my mother’s FP3+ which had a strange issue: the battery completely discharged when using it and we were not able to make it charge again: it was stuck in a loop of BlueFairphoneLogo->1%BatteryWarning->Reboot. I was charging with an external charger so I tried charging it from a computer (MacBook Pro) and it worked, the battery charged completely.

Now the phone is charged, turns on and off and works just fine. The fact is that I am not able anymore to charge it when it’s on. It only charges when it’s turned off. More specifically:

  • Charging from a computer: charges only when the phone is turned off
  • Charging from original Fairphone charger with original Fairphone cable: doesn’t charge, regardless of the phone being on or off (but the charger works, I was able to charge my Pixel6 with it)
  • Charging from third-party charger with third-party cable: only charges if the phone is turned off.

Please notice that when the phone is on and I attach a USB cable it looks like I didn’t attach any cable at all: the icon doesn’t turn to the “charging” one, the percentage doesn’t grow (it actually discharge, if I leave it there). If attached to a computer I get the “device charging” notification but in the dialog I can’t change between “USB connection controlled by other device” to “USB connection controlled by this device”, it just says “Can’t perform commutation” (the wording could be different, the phone is in Italian). I tried enabling “Debug USB”, nothing changes: I still see the same notification, I was not notified of any device trying to debug and didn’t have the change to enable it.

Also, yesterday I opened the phone and removed the bottom module, thinking that it might be an hardware issue. The bottom module looks fine to me, it’s clean and not dusty at all, I even cleared it with contact spray.

What do you think could be the issue? A “standard” failure in the bottom module, so I should hope for a restock soon? It bothers me the fact that when the phone is turned off it just charges, only with some chargers (and not with Fairphone’s one, though).

Thank you for any information you’ll be able to provide

Modern chargers do usually communjcate with a phone to negotiate voltage, control charging speed, and so on. It may well be that the default behaviour of each charger is a little different if no proper communication with the device is possible. So imo its not utterly absurd to observe varying behaviour with different chargers if one of your USB-C port’s data pins were to be corrupt.

1 Like

Thank you Andreas! Corruption of USB data pins would also explain why plugging into a PC just charges (if the phone is turned off) and doesn’t allow data transmission.

What I wonder is: why does it charge only is turned off? Maybe there’s some check by the OS that prevents charging if there’s no communication with the charger, while this doesn’t happen when the phone is turned off?

I have exactly the same issue you described, except for me it makes no difference whether I plug it into a computer or a normal socket. When I plug it into a computer I get an error message:

USB device not recognized.
The last USB device you connected to this computer malfunctioned, and Windows does not recognize it.

My phone screen also keeps turning on, showing the Fairphone logo, then the current charge state (1%) and then turns off. Whenever it turns on, Windows shows the error message.

I will borrow a different battery later the day to verify if it’s a problem with the battery or with the USB connector.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.