Fairphone 2 - USB completely non-functional (Win7 SP1)

The USB connection between my phone and PCs just doesn’t seem to exist from any device’s perspective. The normal USB options don’t show up on the phone, and the PC doesn’t register that something is plugged in. I’ve tried all my cables on both my computers, and many of these combinations used to work at some point in the past. What happened?

I tried ADB driver, which doesn’t find anything (nothing appears in the peripheral manager), and nothing USB-related appears in the “Storage and USB” section of the settings menu.

How can I get to the data on the phone? I need to make space while keeping the data, and I can’t face transfering 9GB of pictures one-by-one to my Google drive…

1 Like

As it looks there is only the way by using a sd card to swap data. But this requires to not have your phone encrypted and if there is any sd card it should be used as external storage, which is unlikely to be when used with Marshmallow. But this should be clarified first.

Does you phone still charge or is it completely ignored by any attached device?
Maybe then the bottom module is faulty.

1 Like

First you might try to take out/disassemble the module, clean the contacts and reassemble it.
The troubleshooting tool does not seem to offer any additional advice.

If this does not help:
Try contacting one of the #fairphoneangels or a fairphone community near you (there are more and more everyday), that can be located on the #communitymap.
There you may find someone able to check if your bottom module is defectife (or anything else) by swapping modules.
Should there be no community near you, you could try finding a helpful user here by posting the area where you are living.
And finally there is always the option to #contactsupport.


You can use Google photos or Dropbox to upload all pictures at once, no need to do it one by one.

The phone still charges.

The problem with DS cards is that the only thing I have that reads micro-SD cards is… my Fairphone!

That’s fair. I might do that.

I still want to be able to access my phone on my computer though. =P


What you could try is to connect the phone via USB to your computer, then go to the Android settings -> Developer options and turn “USB debugging” on. It does then somehow register the phone on my computer and I’m able to select the MTP/File transfer mode for data transfer. It’s kinda strange and you do have to toggle “USB debugging” off and on again each time you connect your phone to the PC.

No idea what the cause for it would be, but I hope it get’s fixed eventually.

If it still charges there may be nothing wrong with the µUSB port itself.

Since it worked once with your pc maybe try if you have another option if it´s properly recognized on a different computer.
If so It could be that your Windows usb driver cache is somehow messed up. One way to clear it would be reinstalling your driver for the usb hub / host controller from the device manager.

Enable developer options.
Enable USB debugging.
Then in the menu option “USB-configuration”, set MTP (Media Transfer Protocol)

Yes, this works. But I have to do this every time I connect my phone to the computer. Is there a way to make this the norm / standard?

Probably, but I don’t know how. It doesn’t really bother me too much.

Seems to be an intended default setting. Maybe you want to read some more about this here.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.