Fairphone 2 Ubuntu Touch

Hi Chrissie,
I have a suggestion but I’m not totally sure it will work. Firstly, the Terminal program on Mac seems to be based on the Linux version, so you could follow command-line instructions. Secondly, you could also create a bootable Ubuntu USB, boot into it with your Mac, and just use the trial version of Ubuntu to run the tool. It doesn’t install Ubuntu to the computer, just runs it from the USB.

Good luck this Summer!

Hello !
Some good news from UBPort blog:

Stable OTA-1 is shipping! (except the Nexus 4)

The UBports project is proud to announce Stable OTA-1 for all of our officially supported devices.

This was the most exciting news for us. OTA-1 is the culmination of our efforts over the past two months. It brings many bug fixes and enhancements to the platform, including:

  • Experimental AGPS support
  • The UBports Welcome app
  • The amazing OpenStore
  • Terminal and File Browser are preinstalled (It’s the little things!)

As well as bug fixes for the UBports ported devices. You can see a list of bugs targeted and closed for this release here.

I’m really excited by the fact that the UbuntuTouch development is continuing despite the canonical drop, now thanks to Patreon crowdfunding, Marius Gripsgard began working full time for UBPorts!:smiley:

As soon as I tried this first OTA, I’ll let you know my feedback ;-). I’m also excited for the two project currently in development :

  • Halium: a common base for all Linux-based OS, allowing new developments to be less hardware-dependant…
  • Anbox: “Android in a box”, to allow applications developed for Android to run on GNU/Linux distributions.

I just installed the OTA-1 version of UBPorts’s Ubuntu Touch, and it runs flawlessly, with a little orange robot as the new mascot :slight_smile: .

According to the Telegram “super-group”, it was not possible to upgrade from a former version, so instead I used the magic-device-tool for a fresh install. The only difference was in the channel selection screen, instead of devel_rc-proposed (which doesn’t exist anymore), the (now only possible) channel to select is legacy.


Good to hear, I am migrating this weekend finally :smiley:

1 Like

Once installed and running, UbuntuTouch was not recognised by my computer (*)
In order to fix that, here are the steps:

  • Enable developer mode (About this phone > Developer mode > Activate)
  • On the computer, add the following line in terminal: echo 0x2ae5 > ~/.android/adb_usb.ini (thanks to @NeoTheThird)
  • Then reboot the adb daemon ( sudo adb kill-server / sudo adb start-server)

adb devices gives now:
List of devices attached
0123456789ABCDEF device

(*) Actually, adb recognise the device in recovery, and fastboot recognise the device in bootloader :blush: But before the manipulation, no detection within UbuntuTouch system…

EDIT: I found out that this information is already described in the UBPort wiki :slight_smile:

1 Like

Can you already install Anbox ?

As far as I know, Anbox doesn’t work at all on Ubuntu Touch yet.

From their website :

If your system doesn’t support snaps, then we currently don’t have an easy way for you to install Anbox. However, this might change in the near future.

And snaps are available on Ubuntu 16.04 LTS or later; UBports Ubuntu Touch is currently running 15.04…

A funny thing: it seems that TWRP doesn’t recognize Ubuntu Touch as an operating system… Each time I reload my UT image with TWRP, when I reboot I get the following warning: No OS Installed! Are you sure you wish to reboot? This is not really annoying as this is only a warning and can be skipped easily… @z3ntu, are you aware of that?

I was able to get back my configuration of Dekko (mail client) from a former Ubuntu Touch image :slight_smile: .
The files of this application are in those directories: ~/.config/dekko.dekkoproject and ~/.local/share/dekko.dekkoproject; but I found out that all the settings I need are in one file: .config/dekko.dekkoproject/ dekko.dekkoproject.conf.

  • To backup the settings: adb pull /home/phablet/.config/dekko.dekkoproject/dekko.dekkoproject.conf
  • To reload the settings: adb push dekko.dekkoproject.conf /home/phablet/.config/dekko.dekkoproject/dekko.dekkoproject.conf

I don’t know how the “TWRP OS detection mechanism” works but it’s surely not my fault. You can report the bug at TWRP if you want it fixed.

1 Like

I successfully synchronised my calendar and my contacts with my ownCloud server (via CalDAV and CardDAV protocols) on UbuntuTouch. :slight_smile: Thanks to @bastos77 and @tcarrondo! This is done via a script as there is no GUI for that yet…
I made a wiki page to help others also interested.

1 Like

I wanted to try Ubuntu Touch on my FP2, but I can’t figure how to install it.
From the ubport site, I only find the MDT as installer, yet this requires Ubuntu.
The dl link in the first post isn’t working unfortunately.

Could someone point me to an install guide or to the location where to retrieve the necessary files from?

Hello Freibadschwimmer,
i did not try it, but i found a tool called cpt_o.5.0 somewhere on the UBPort site.
I have installed the tool (but i didn´t flash the Phone )and you can chooce 3 devices inclouding our FP2

Maby u try this: https://ubports.com/page/fs-flash-phone


Good answer @Mani :slight_smile: ! Just for information, CPT stands for “Cross-Platform Tool” :wink:
And this is a good alternative to MDT “Magic Device Tool” for users not running Ubuntu, although it is also possible to launch a one-time Ubuntu session on your computer with a live-USB or live-CD…

1 Like

oh, thx for the flowers…

But now i got a question about the ubport for the FP2. I am on FPOOS for a few month, and i like to switch to UT only for fun and mayby for ever :slight_smile: I only need a client for Whats app, because every one contact me with this app. Is it posible with a Webapp or something else?

I haven’t tested yet !
But with a search on the Telegram group, it seems that for Whatsapp and XMPP protocols you can use Loqui IM, an app recently ported from FirefoxOS to UbuntuTouch, available on the OpenStore (github source).

1 Like

Ok, thank you very much.
And what about the contacts? Are they there on the ubuntu touch without big problems? Or is there a lot of Homework by tiping all numbers by my selfe in the Phone?

For contacts, you can either import them from Google (sic!) or from a .vcf file you exported before… Personally I set-up a two-way synchronisation with my ownCloud server, using the CardDAV protocol (see post 152 on this topic…)

1 Like

Is it still the case that CPT installs an oild version and MDT is required for the latest updates?

When I tried a few months ago, I in the end needed to install Ubuntu on an old laptop because CPT couldn’t get the latest version and MDT could (and the difference was pretty big, lot of fixes in between, according to the devs).

Hey guys, sorry i haven’t visited this thread for a while…

Ubuntu Touch is still very much alive and we at UBports are delighted to see the community interest in the project! We’re currently ironing out the final issues planned for our next stable release OTA-2.

You can follow the instructions on this page for installation from Linux, Windows and macOS. If you’re feeling like trying something on the edge, you can also check out the UBports installer, but that’s still in beta.

Whatsapp is a problem. Yes, in principle loquiIM works, but it has a lot of problems.

The CPT should work.


Great to hear, that Ubuntu Touch is still alive for the FP2.

All the work people like you are putting into developing alternative OSs for the Fairphone can not be valued high enough!
In my opinion it helps to reach the task of making FP a really smart-phone.
Having visited the ubports website, I am really tempted to try it on my phone.
But as I have no experience whatsoever with any Linux distribution, would you consider it a wise and senisble decision to start using Linux on a smartphone, or should I try it on my laptop before?
Btw. I do not intend to start programming and really hope to be able to avoid command-line work to the max. :wink:

1 Like