Fairphone 2 Ubuntu Touch

Yes. Works smooth calling and getting calls. Once I had an echo problem but only with one peer.


Hi pat !
I don’t know about version 14, but I know that from version 9 to version 10 the GUI was broken, as it is stated in post 1 of this topic :

What I advise you is to try one of the two working methods:

Best regards,

1 Like

Hi oli, thank you.

I just saw the PDF tutorial and deleted my post after this.

I think there are some problems regarding the fact that version 14 is not available:

  1. my SIM card wasn’t recognized by UT and i didn’t get asked for my PIN. will this problem be solved after setting the provider data manually?

  2. CalDAV and CardDAV does not work with UT 9 or UT 10, is it right? I just saw the shell script for sync with ownCloud, but i need both for SOGo. Does someone know a solution for this issue?

  3. I recognized that that 4G isn’t available, but probably it depends on the fact that SIM isn’t recognized

If it is possible to solve these three issues, i would definitely use UT on my phone and support the developement as effectively as possible

1 Like

Hi pat!

The versions you are mentioning, for my understanding, are from the stable channel. If you want fully working device you should install via the rc-proposed or devel_rc-proposed channel, one way to do so is using the Magic device tool already mentioned some posts above.

I’m using version 251 from the rc-proposed channel and right now I can assure you that both the sim cards are automatically recognized and 4G is working. For what concern CalDAV and CardDAV I don’t know. In case you could consider to join the telegram chat Fairphone 2 + Ubuntu touch (link above) people are very welcoming and they helped me a lot.



Thank you, aronne. I’ll give it a try now

1 Like

hi people. i’d like to ask those of you who have deeper insight into the technical aspects regarding the move from click to snap. as far as i have understood, the fp2 will not be capable of running snap packages, right? in the light of reading that the email client dekko will no longer be developed (while still getting bug fixes) for click but only for snap i wonder, if using ubuntu on fp2 has to be considered as something which would be called “riding a dead horse” in german. meaning: if i would be using ubuntu on my fp2, is there any chance i can run decent software in two years? will the community try to make snap work or will we be stuck with outdated os and software? background: i’d like to have an os which i can use steadily for several years and not to have to switch every second year. right now i am running sailfish os which works quite well, but as we all know, jolla’s future is constantly uncertain. this doesn’t mean i have deeper insights, at the moment they seem to do very well. ubuntu seems nice, too, but as written above, i would want to run an os with abright future.
so, can anyone of you enlighten me and explain what the move means for ubuntu’s future on fp2?



Exactly my problem. Seems to work with SoGO like Owncloud: Look here, but I have not tested yet

1 Like

Hi Juri, I’m don’t have a deeper insight into the tech’ aspect of that move, but on that page from OMG!Ubuntu, they say that it will require an newer version of the Android kernel. So, maybe Android 6, which should be available this year for Fairphone (Android 6.0 Marshmallow / 7 Nougat for FP2?).

That said, I’m absolutely not sure of what I’m saying… Where did you read that the snappy version of Ubuntu Touch won’t work for Fairphone 2 ?

Cheers !

1 Like

Syncing SOGo with the standard calender and contacts works with this script https://gist.github.com/tcarrondo but to get rid of the main error one has to add one line:

export DBUS_SESSION_BUS_ADDRESS=$(ps -u phablet e | grep -Eo ‘dbus-daemon.*address=unix:abstract=/tmp/dbus-[A-Za-z0-9]{10}’ | tail -c35)

Than it works like a charm :slight_smile:

1 Like

I think it’s not only the Kernel, but also the CPU. The Fairphone only has a 32-bit Processor and Canonical wants to focus on 64bit ARM to push Convergence.


Ah, that’s sad… We’re left on the side of the road, then.


Two silly questions as I have no Idea about this.

If I follow the instructions in Marius Quabeck’s Video will I be able to make Calls and use GPS?

How do I get the original Android working back again? This is in case something goes wrong.

1 Like

Normally, yes (I didn’t flash Ubuntu Touch). But choose to flash your phone with the devel_rc-proposed channel (the stable one doesn’t provide all functionalities). If you want to return to Android, don’t forget to backup your phone !!

You can do it with the Teamwin Recovery Project (TWRP), booting your phone to recovery (turn it off, and press the power button + volume UP) and choosing the backup option.
Or you can backup your phone with the Android Debug Bridge tool (adb) with the command adb backup -f -apk -shared -all. You will be prompted to unlock your phone and accept the backup. It will create a file on your computer that you can use to restore your apps, contacts and so on.

As Ubuntu Touch is still based on an Android kernel, it’s still possible to return to Android (I assume you have Linux on your computer for the following instructions)…

  1. Check that you have the android-tools-adb package installed
  2. Check that your FP2 can be detected by your computer, check your udev rules if not
  3. Put your phone into fastboot mode (turn if off, and press the power button + volume DOWN)
  4. Open a terminal and tap fastboot devices, if a message like “920101 device” appears you’re on the right way
  5. If you want to install Fairphone Open, go on this page and download the manual installation with a script package, go with the terminal to the file where you put it, unzip the package and tap ./flash.sh. The script exectutes itself and installs the latest version of Fairphone Open on your phone.
  6. If you want the stock Android version (with Google apps and services), go to that page and download the latest Fairphone OS image. The procedure is the same as the one with the Fairphone Open image.

To restore the data on your phone with the backup image (created with the adb backup command), open a terminal, go to the folder in which your backup file is, and (assuming your phone is connected to your computer), tap adb restore 'name of the backup file'. For the TWRP image, I don’t know as I never used this trick.

I hope my post is understandable !! If not, please excuse me :wink:

Source for the adb commands : https://developer.android.com/studio/command-line/adb.html


Hi Spartid

Thanks a lot, I am still stuck in the first step.

Installed the android-tools-adb using > sudo apt install android-tools-adb
Then tried backing it up, it said > adb: unable to connect for backup
Then tried checking adb devices, It didnt show anything,
Then tried lsusb command This is what i get

Bus 002 Device 003: ID 5986:02d2 Acer, Inc
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 147e:1002 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 001 Device 004: ID 8087:07da Intel Corp.
Bus 001 Device 003: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 017: ID 2ae5:904e
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

*The phone USB computer connection is in PTP mode.

Then read that I have to add the vendor code and product ID to the rules file i added this line to it

SUBSYSTEMS==“usb”, ATTRS{idVendor}==“2ae5”, ATTRS{idProduct}==“904e”, GROUP=“users”, MODE=“0666”

And here I am stuck. Nothing more happened after this. I just wanted to create a backup, but figured out that phone isnt getting detected. Actually there is nothing important to back up. With the phone not being detected didnt want to risk installing.

1 Like

Hi @nithinrao !
The detection of phone by adb is not only useful for backup, but is also a mandatory condition for the installation :slight_smile:

  • go to settings, developper settings (you might have to unlock this hidden menu - tap 7 times on the build number in settings) and activate USB debugging.
  • when connected to USB, uncheck all boxes in USB connection popup.
  • then a prompt will come on your phone with a fingerprint to accept.
    That could do the trick !
1 Like

Thanks @oli.sax, I completely forgot to mention this ! It actually will do the trick :slight_smile:

And @nithinrao, I also forgot (sorry :frowning:) to say that it may be necessary to reboot your computer to take the new udev rule into account. You can also restart again udev by tiping the command sudo service udev restart and connect your phone.

1 Like

According to their ub4fp website, the battery drain issue could come from a different cause…

Note a: The current version of our image is constantly searching for devices (GSM/GPS) and therefore consumes a lot of battery power.

By the way, I just installed the devel_rc-proposed version of UBports with the magic-device-tool and the installation is really easy, that is magic ! :slight_smile:
PS: Calls are working and Dual-SIM as well, good works guys !

1 Like

Hi all

I just gave Ubuntu Touch a try on my fp2, installation worked flawlessly using ‘the Magic way’. One thing I tried first is to replace the white background of the scopes with a custom wallpaper, as proposed here. However, this did not work, the standard background file (paper_portrait@27.png) does not even exist. Then I realized that the background of my scopes is actually perfectly white, not the greyish shaded appearance as shown in the screenshots. Is this to be expected or is something wrong with my installation?

1 Like

Hi there,
I also did the magic and everything seems working but mobile data.
The cellular data switch is light grey and can not be switched on.
Any hints on how to enable this?

1 Like