Fairphone 2 rendered unusable after TWRP update


I am afraid I‘ve totally screwed up my Fairphone 2.
It was working fine with FPOOS 17.11.2.
It had TWRP Version 3.0.x.x which didn‘t work so fine, because it did not write backups to my SD card (64 GB) and it didn‘t save my preferences (language setting etc.). So I installed TWRP 3.2.0. And there the problems began. Installation went flawlessly and TWRP worked fine afterwards. But I got stuck in a bootloop afterwards. I could not boot up the system any more, the phone always booted just to TWRP.
I had made a backup of my system of course, but TWRP could not install this any more (it always complained about a defect file system, I can‘t remember the exact error message, sorry).
I tried many things, but things got worse all the time. I the end, all I could install was FP 1.13. (Android 5.1). But this is working extremely slowly, and it doesn‘t seem to have any apps installed. It just shows the screen with four icons at the bottom (Google, updater, notifications and play store). Google search bar is there also, but it does not accept any input. The „all apps“ icon is missing, so I cannot even get access to Amaze to browse the file system. TWRP ist gone, too (Android 5.1).
The Updater app is still there, it recommends to udate to FPOS 17.11.2, but the update doesn‘t work. The phone gets stuck when shutting down, after restarting the crippled FPOS 1.13. is there again.
I can access the phone via fastboot and adb. But trying to install fp2-sibon-17.11.2-manual or a Twrp image always is aborted and I get a the message „E: footer is wrong, E: signature verification failed“. I am afraid there is a very severe failure in the basic file system of the phone, but I can‘t trace or access this. Performing a factory reset doesn‘t help either.
Does anybody know what sort of problem this could be (and of course, how I could repair my phone)?
Many thanks in advance,


How exactly did you install it? Did you use the App or did you flash it manually?

Two ideas:

  1. Volume Up button got stuck … not likely because you can now boot Fairphone OS, it would boot into the stock Android recovery everytime now with the button being stuck.
  2. TWRP was installed into the wrong partition, if that’s even possible (don’t know). Did you exactly follow the “Fastboot Install Method” at twrp.me?

You can boot TWRP without flashing it and then wipe your whole phone clear and install TWRP and the OS from scratch.

1 Like

Is it possible that you installed TWRP to the /boot partition? This could be the explanation why TWRP always boots.

What happens when you choose from within TWRP: Reboot -> System ?

I think you can fix this by flashing the original boot.img from the FPOOS version you are using.


I just installed TWRP 3.2.0-0 following the guide at twrp.me and TWRP as well as the OS still work fine.

You are right, this might be the problem, I installed TWRP to the boot partition. I’d really like to clean the whole system, but a factory reset obviously isn’t enough, I’ve tried this. I only have some zip files of older FPOOS versions and one of FPOS 1.13. I could not find a boot.img. Can you tell me where I can find this? And should I flash it via fastboot? TWRP is no longer on my phone, but I could use the recovery system of Android 5 (the robot lying on its back).

Please keep calm. You seem to try a lot of things without thinking about them. :wink:

Re-Flash FPOOS with the second method from this guide.


Thanks very much for your advice, I will try to follow it. At least I will refrain from physical violence against my phone :smirk:
Installing TWRP into the boot partition obviously was a mistake, I admit that. I have tried to flash FPOOS the way you suggested. But when I execute the script (flash-for-windows.bat) it starts right away, but after a very short while the procedure is aborted and the phone shows the message „E: footer is wrong, E: signature verification failed“. It has done this several times concistently, so obviously there is some problem there. And I don’t know what E: footer and E: signature means and how that could help me.

Now that we know TWRP is in the wrong partition, you just have to flash it to the recovery partition, directly boot into it afterwards (don’t boot into Fairphone OS afterwards as it will replace TWRP with the stock recovery again) and continue here as already suggested …

1 Like

This means, that the verification of the files failed. Did you try re-downloading the image? :wink:

Thanks very much AnotherElk and retsifp. I will try to flash TWRP to the recovery partition. I won’t be able to do it today because I am very busy at the moment. But I will let you know if this could solve the problem. At least you could show me where the problem lies. Thank you both once more for your quick help and your good advice:wink:!

Hello again. I’ve had a busy week, but nonetheless I found the time to repair my phone. I could run it in a fairly basic version of FPOS 1.13. After (reluctantly) registering it with my old googlemail account (and receiving lots of unwanted offers from Gxxgle), eventually I could update to FPOS 17.09 and from this to FPOOS 17.11. So now I have a working FP2 again! After much work it is in the same condition it has been two weeks ago…
I have learned some things, though:

  • never, ever, change a running system
  • keep calm (thanks @retsifp!)
  • FP2’s tech specs might not be top notch any more, but you can run it on a Gxxgle free OS, and that is really great (having had to experience standard Android for some days…)
  • and last, but not least, FP2 has a really great user community!
    So, thank you all very much who gave me good advice and thus helped me get my phone get going again!
    Have a nice (and not too busy) pre-Christmas time,



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.