Fairphone 2 not charging even with new battery

Hello, brand new member here. I got a secondhand Fairphone 2 about six weeks ago. All was ok until the battery started getting really hot. Then it wouldn’t charge. I bought a new battery but that too is not charging (the red light comes on but just stays on and nothing else happens.)



1 Like

This can have at least four causes: The battery itself (well, it seems that isn’t the one here), the bottom module, the charging cable or the charger.

Have a look here to systematically narrow down the culprit:


Thanks! I’ve tried several different cables (and they work with other devices). I also tried cleaning out the “port” where the charger goes in. No joy.

Maybe a new bottom module is needed?

Thanks again

1 Like

Hi, is there a trick to getting the screen off? I’ve slid the two blue buttons in towards the middle but the screen is not moving. Thanks again

1 Like

Have you taken out the battery? And the black rim (the smaller part of the case)? Other than that, the first removal of the display module is always hard.



I have managed it, just a bit stiff.

So, I’ll try removing the bottom module.

Thanks again and sorry for being a pain

1 Like

Replacement bottom module now ordered; hope the new one does the job.

Thanks again

1 Like

OK, bottom module changed but phone still just showing single red light when plugged into charge. Basically, no change.

So it seems it’s not the battery or the bottom module. Can I return these parts to Fairphone?

Also, any ideas what it might be?

I’m worried that the hot battery might have done some serious damage to something, somewhere.


Have you tried letting it charge full with the FP2 kept switched off?

One more idea: Try if charging works when connected to a computer.


Not sure what you mean by “letting it charge full with the FP2 kept switched off

At the moment the screen is black / blank and the red charging light is on solid

Just plugged it into a computer, let’s see how it goes!

Thank you again so much for your help

1 Like

Ah ok! Well, usually it should show an animation of the FP2’s interior (with the battery graphic showing charging), but unfortunately yours doesn’t. I’m starting to wonder if there’s something wrong with the display.

If you can keep checking if the battery runs hot from time to time, you could try if the red LED ever turns green (but this could take an hour or more likely two or longer).

Thanks. With the charging light still on solid red I think I might just cut my losses.

Do you know if Fairphone will accept the return of the battery and bottom module I bought?

Thanks again

What happens if you plug the phone without the battery?

They may. Are you still under the 14 days return period?
I remember cases in which they accepted. In any case contactsupport , asking won’t harm!

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.


Did the new USB-Port Module yield any results?

I have a similar issue. Except for a FP2.
A heavier drop (popped some plastic off) is the only recent misuse that I can recall.
I tried several Charger/Cable combination.
I also went trough a manual OS-Install several times.
In between I dismantled the whole phone and cleaned all the contacts.

The behavior stays the same.
No charging. Except for some initial “juice” until the Blue Battery Shows up.
This is the part that bothers me the most.

So, I dug up a cheap USB-Voltage display and observed, that approximately 1.5A is used during the “red led blinking”-phase.
I guess, until enough power is charged to run the “blue-battery” display.
I noticed that the battery got a little bit warm, when I re-installed the OS.

What I came up with, was to drain the battery until it would boot into “red led blinking”.
Then I would hold volume_down and power, and plug in the charger.
This takes about a minute, but this way I can enter the fastboot mode, and there is a 1.5A usage on my power-monitor-dongle, while the phone is getting warm and the LED is blue.

This is the state right now, and I will wait for about 2hours, to get a fully charged battery.
In the previous run, where I had enough juice to fully boot into the wiped OS for a couple of minutes. Everything seemed to be working fine. No inserted SIM/Sdcard, but Sound, Camera, wifi … all good.
But it did not recognize the available Power at the USB port and started charging.

I am really curious what the Issue might be. I had this device for about 6 years now and already changed the port-module and the battery about two years ago. Back then the USB-port was clearly wiggled out and the whole thing was a minor cost.

Welcome to the community forum.

I reopened this Fairphone 2 topic and moved your post here, should be a better fit than the Fairphone 3 one :wink: .


Okay. I had the new Bottom Module for 23 Months now.
Order Date was September 26, 2019.
They are “permanently out of stock”.

If I can’t repair the charging Issue, and quick part replacement is not possible, I might have to buy the latest iteration.
Maybe this 2016 Device ends up as a fancy TV-Remote when those fp2-new-usb-c-bottom-modules become available sometime.

1 Like

You should have 1/month of warranty for the bottom module, so please contact support and see if they feel they can replace. For those cases FP kept modules on stock.
The USB c module is not officially sold by FP and I assume it will never