Fairphone 2 Lineage OS 15.1. TWRP

I don’t know if this is the right place to place my question:
I run on a fairphone 2 a lineage os. Actual it is the 14.1.2018-08-08 version. Lineage OS offers an upgrade to 15.1.x. It should be downloaded and be manually installed. I run a twrp version 3.0.2-0. This procedure fails: “This build is for: FP2 while you have: .”. I found a hint here: https://www.reddit.com/r/LineageOS/comments/99hm8p/cannot_upgrade_to_151/
So I upgraded twrp with the official twrp app to device: FP2 and version 3.2.3-0 FP2. After that the device reboots but hangs. After removing the battery and reinserting it the phone started again but hangs. Trying to get into recovery-mode with pressing power button and vol-up button: no success. The phone again hangs. After an additional reinsert oft he battery and pressing the power button the system starts the formerly installed lineage os 14.1.
Who can help to reorganise the twrp environment in order to install a lineage os 15.1.x??

TWRP supposed to be updated prior to upgrading LineageOS. The first one you have just finished, since I could read from your message, that afterwards you have tried upgraded LOS, now upgrade LOS. I believe it should work out now.

Didn’t help at all. Guess my boot partition was damaged, as I got a “partition table doesn’t exist” during working around with adb which temporaly bricked my phone.
After looking around in the web I found a hint for flashing a new boot image:
I am not able to tell you where I found it. Flashed boot sector via fastboot flash boot … did it.
The formerly installed twrp 3.2.3 appears and automaticly restored the partions. I was able to restore my backup etc…


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.