Fairphone 2 Dual SIM: 2G disabled by provider


I use two SIM-cards: 1) my private one (mostly for calls and SMS) and 2) a company card (calls and mobile data). This worked well so far: since I didn’t want to use the mobile data on my private SIM, I just set it to 2G, disabled mobile data and used 4G on the company SIM.

Now however, the provider of my private SIM has turned off 2G. As a consequence, the SIM won’t connect anymore, unless I configure it to 3G or 4G (event though I don’t want to use its mobile data). This means, that the company SIM has to be set to 2G.

So whenever I want to actually use mobile data now, I have to switch my private SIM to 2G, the company SIM to 4G and then my private SIM disconnects which leaves me unable to make or receive calls on that number.

Has anyone a fix around this problem? Is there some kind of update possible to a fairphone 2?

Kind regards,

This sounds like needing an alternative to calling by 2G. New options would be VoLTE/VoWiFi which FP2s design in general can’t handle afaik.
If you don’t want to switch phones you may have to switch for an operators who still provide 2G network service.

Even though having VoLTE on the FP2 would be highly appreciated this isn’t a solution in this case. FP2 can only have one SIM at any radio access technology (RAT) greater than 2G. So if the company SIM card shall be at 3G/4G then for the private one we only have 2G left and this doesn’t work obviously. VoWiFi could help if WiFi is available. But VoWiFi seems even further away than VoLTE. However without the RAT limitation the phone could still call on 3G.
Long story told short: I agree with Patrick’s conclusion: Change the operator of your private number or change the phone or live with it :confused:

Hi Patrick, hi Martin
Thank you for your quick reply. I was afraid there might be no other solution but it was still worth to ask :slight_smile:

I’ll figure out whether the provider of the company SIM plans on disabling G2 soon too and then decide based on that.



Hi Stefani,
once I had a problem on my FP2 (LOS 17.1) with the data speed. Then I learned, to put the SIM for the data usage in slot 1 of the FP2. I do not have profound knowledge about this issue, but maybe it’s worth a trial to change the SIM cards.

Hi peace
Thank you for your suggestion. It didn’t solve my problem but it was well worth trying.

I’m waiting to see what happens if the provider of my company SIM disables G2 to. They plan to do so soon and I don’t know if that SIM-card will disconnect as well when set to 2G.

Fun “bug” I just discovered: when I am on the mobile network settings page and switch fast enough between the SIM-cards I sometimes manage to set them both to G4. I don’t actually get G4 but Edge but if it helps to keep both SIMs connected I’d be happy enough. Don’t know yet how it works in the long run (it gets reset on reboot).


1 Like

Hi Stefani,
good to know about the bug! If I run into this problem, I’ll try it, too.
Thanks and success with a ‘mogic solution’!

Hi Stefani, could you share which operators you are using for private and business so other users with the same operator will be able to find this thread?

By the way, the Fairphone 3 supports two SIMs on 4G so you could consider buying a second-hand FP3(+) if you can’t find a satisfactory solution.

1 Like

Update: the second provider has now discontinued its 2G support as well and my second SIM card has the same issue as the first: it can not run in 2G mode even if I have mobile data turned off. Thus I’m only reachable under one number and have to switch if I want the other one to be enabled.

Switching between the SIMs is not as straight-forward and deterministic as I’d like it to be, if anyone runs into problems here a list of steps that eventually lead to the SIMs beeing switched.

  1. Settings > More > Mobile Networks: Set the preferred network type to 2G for the card to disable and to 4G for the other card
  2. Settings > SIM cards > Preferred SIM for: Switch Mobile Data to the card just enabled
  3. wait a bit, if the SIM does not connect properly or mobile data is not available, do the next points in random order until it works
    3a. reboot the phone
    3b. disable and re-enable mobile data
    3c. perform step 1 twice (switch back to other SIM card and then again back to the one I want)

The bug mentioned in my post for January 29 is unfortunately a UI-bug only; if I manage to get both SIM cards set to 4G, none of them will connect to its network, no tricking them :wink:

Thank you @AlbertJP for your feedback and the hint about a secondhand FP3, haven’t thought about that.
My providers (Switzerland) are

  • UPC (private SIM): discontinued 2G by the end of January 2021 AFAIK
  • Swisscom (business SIM): discontinued 2G by start of April 2021 in my region, might differ for other parts of Switzerland


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.