Fairphone 2 can't complete start after OpenOs + Xposed upgrade


After 1 year working fine, I was starting to have geolocating problems with my byke app on my FP2 / OpenOS / Xposed.

I first checked for an update of the OS which I did (can’t remember which version, should be the latest 19.02.1). The phone booted fine but still no geolocation: app crached after attempting geolocation (some null pointer exception in the logs…).

Reluctantly, I tried to uninstall then update Xposed, I think I had SDK23 (Android 6.0) and it tried to download a SDK25 (Android 7.1). Think the first reboot was ok.

When I tried to update the modules however, The phone was unable to complete boot, it starts I have the animation but then I have a blank screen. However, the power button is reponding and if I press it I have access to the reboot / shutown menu.

I can also access TWRP, wipe caches but no success.
I tried to create a disabled file for the module but the directories doesn’t match with what I have found on internet.

I also tried to adb logcat my phone to try access the logs but the device is unauthorized, I don’t feel like typing the whole pub key in TWRP terminal, I could mount the ext SDCard on ubuntu as RW but couldn’t place the key on car, vim tells me the file seems to be RO.

Could you help me?


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.