Fairphone (1st batch, with storage upgrade) not properly recognized by PC

Hey everyone,

my Fairphone (1st batch, with the storage upgrade installed) is not properly recognized by the PC (Win).

When plugging it in, I can choose “USB storage” and “Turn on USB storage” in the next step. However, then the problem occurs: the PC will recognize the SD card only as a removable device. The phone (internal storage, that is) is not recognized.

The phone itself works perfectly well with the internal storage.

I’d love to hear if anyone has ideas about this issue or encountered it before.


1 Like

Hey Ivo,

welcome back to the forum (and once again sorry for mistakenly deleting you).

I don’t know anything about connecting the phone to a windows PC but did you try with a different cable? Also you could enable USB debugging (in settings > developer options) and see if removing the SD card makes a difference.

I don’t have a Fairphone yet, but with my Samsung phone I use MyPhoneExplorer to connect to my PC. In order to use this, they tell you to turn the USB settings to ‘charge only’. Is that possible on the FP?
Enabling USB Debugging definitely makes sense to have access to the phone!

1 Like

Don’t worry - there’s nothing wrong with your phone! (At least, that I can tell from your description). Due to changes in the fairphone’s partitioning layout during the storage update, USB storage mode indeed no longer gives access to the internal memory. MTP mode works fine for access to internal storage on a windows machine.

1 Like

MTP works well on Ubuntu as well. On Mac you need https://www.android.com/intl/de_de/filetransfer/

Hey everyone,

thanks for the quick suggestions. :smile:

I have tried:

  • a different cable (which was working with another Android phone)
    -> no difference, problem still existing
  • debugging USB options (both
  • with the option “USB storage” (-> same initial result) and
  • with “MTP” option (-> no result, nothing is recognized; however, the PC does still play the sound it plays when recognizing a device, while Windows Explorer does not show any removable device)

As with the USB debugging enabled, if it is disabled, choosing the MTP option does result in the PC recognizing either the internal storage or the SD card.

Unfortunately, removing the SD card does not change the above described results.

Do I need to change any settings when attempting to connect using the MTP option?


Hey Paul,

no worries, mistakes happen. :smile:

All the best and thanks for moderating.


1 Like

In my case MTP is quite slow on activating autoplay (takes a minute or two after the new device sound before I suddenly get a pop-up). However, as soon as I hear the new device sound, I can already see the FP1 in explorer like so:

If you can’t see it there, can you see any problems when you open the windows device manager? The FP1 should show up under portable devices when using MTP mode.

Hey Johannes,

thanks for the help. It seems this could be the right track… :slight_smile:

After having waited for several minutes after the sound without the Fairphone appearing in Win Explorer, as in your picture, I assume something is wrong there.

When checking the device manager, it only shows an unknown Android phone (see picture below).

I tried to install the drivers (via the Windows automatic installation guide), and nothing was found.


I think that device is related to having USB debugging on. It shouldn’t matter for MTP access that it’s not recognised. I can’t verify that at the moment (can’t use the phone right now).
There should be another device for MTP (USB MTP device), though you may find an android composite device or google ADB interface instead. You’ll need to expand the other categories, as chances are there’s a driver installed for them. If you find any of those, try to update the driver, choosing Browse my computer […] > Let me pick […] and then selecting USB MTP device.


The above results were all with USB debugging turned off.
Following your response, I checked the other categories; however, no other device appeared/disappeared. When plugging/unplugging the Fairphone (set on MTP connection mode).

The only thing I could get to change was, by turning USB debugging on, to get the “MT65xx Android Phone” disappear and be replaced by “MTP”:

I assume this is what you were mentioning @Johannes isn’t it?

I didn’t quite understand what you were referring to after this: [quote=“Johannes, post:10, topic:8762”] There should be another device for MTP [/quote]
Could you kindly reiterate?


I mean that the phone can expose two devices to the system. I have the google USB driver that comes with the android SDK installed, so my system looks different, but as an example:

Where “My HTC” appeared when I installed the google driver (and MT65xx Android phone disappeared). The more important one is the second device: the FP1 entry under portable devices. I’ve also seen it appear as “USB MTP device”, but I’m not sure whether it was working properly then.
In some cases there are some issues with the driver that’s loaded (e.g. see here and here) e.g. if you have the google USB drivers installed (which probably don’t have). I’ve also read that sometimes rebooting the phone works (maybe start there). I’m unsure why it isn’t working in your case, as the necessary drivers should be part of windows. Hence the suggestion to ‘reset’ the drivers manually to the default version. The first link above explains that procedure in a bit more detail.

Thank you a lot for clarifying. :smile:

So, I tried both tutorials you recommended. The first (recommending to uninstall the drivers) did unfortunately not produce any results except for the phone disappearing and reappearing as MT65xx Android Phone.

Google searching the issue, I found this: http://forum.xda-developers.com/showthread.php?t=1164957 and downloaded the reference drivers [in post#3]; as a result, my phone is displayed as “Android ADB Interface” in the device manager (see picture below) but still does not appear in Win Explorer.

I now start feeling slightly lost. :smile:

I appreciate any comments and help :slight_smile:

Difficult to say what could help - for me uninstalling the drivers via the device manager and/or manually specifying which driver to use has always gotten such devices to work (including some uncommon lab equipment).

For rulings things out: If you have access to a different windows computer, you could try connecting there to see whether it works there. If it does, it’s likely windows. If it doesn’t, there may be a glitch in the phone after all.

If nobody else chimes in with suggestions, there’s always the option of contacting Fairphone support. They may have more experience solving this, as not everybody tries the forums first. For the record (as you’ve tried those steps), the official support article on connecting to a PC is here, and there’s a link to file a support request underneath the social media buttons at the buttom of the page.

I totally can see why. I really can’t offer much help, but just an idea: if you have any custom firewall and anti-virus software, either on your PC, on your phone, or both, you could deconnect your devices from any internet connection, temporarily de-activate those and see what happens.

I had to use some computers with quite restrictive security settings in the past, and I rember that some of the settings messed with external devices (for good reason).

This is really a shot in the dark, but as far as I can see you are quite capable of trying out several other things on your own and surely did so (like rebooting after removing drivers, etc.) - and thus, I am at a loss to suggest more in that direction.

I already tried to rule the ‘windows is affected’-aspect out and did try another PC. However, due to your hint, I tried yet a third one - on which miraculously worked. I assume it’s a problem of my plus the other PC, then. Thanks a lot for pointing that out - without your hint, I would have considered that as ruled out. :smile:

As to the tutorial: I got excited but when I read the ‘tutorial’, my excitement disappeared quite quickly and I’m now thinking about indeed contacting them.

I’ll keep this topic updated if anything comes up.

For now: thank you a lot for your help! :slight_smile:


thanks a lot for the suggestion. I do indeed have anti-virus software installed. Unfortunately, turning it of and trying several of the above steps didn’t yield the desired result… :frowning:

I appreciate your help, even though my PC is kind of stubborn on this… :slight_smile:

Thanks a lot - and shooting in the dark is always worth a try, I’d say. :smile:
All the best,