Fairbuds XL with Debian Bullseye or generel Linux

Hi there,

I got my Fairbuds today, and with Android they are working quite fine. Just my Debian Bullseye Laptop is not recognizing them. They are recognized as Bluetooth Device, but not as Headphones or any audio device.
Is there anybody got them to work with Linux? Any hint to get them to run would be appreciated. BTW, is the firmware and the app Open Source?



Maybe try Debian 12? It was released recently. Maybe Debian 11 doesn’t have the proper drivers since Debian is very conservative with new software, especially since that release was a few years ago already. Other bluetooth devices do work fine? Do you use GNOME?

I tried in the moment with Debian 12, there I got a readable error message > br-connection-profile-unavailable.
I have Mate Desktop, other Bluetooth Devices, even Headphones, work perfect.

I’m testing the XL now on Fedora, it works fine. Actually the sound quality is so much better on my laptop than on my phone. Testing it with the Tenet trailer, which I think is really nice to test high, lows and the clarity of voices.

One thing that doesn’t work is connecting both devices. Fedora works, but then my FP4 doesn’t generate any sound anymore, while connected as second device (as is announced by the XL). Will have to test some more. But it should of course work as advertised and be as user friendly as possible. The order of connecting the devices doesn’t seem to matter, it also shouldn’t matter. I already use this with ease on my own Jabra earbuds.

Also the Fairbuds app is super buggy. More than half of the time it keeps crashing (just saw the blogpost of a new app update, it’s not available for me yet). I guess all of this is part of the poor QA testing of Fairphone.

Edit: I guess I found the fix. I long press the ANC button to go into pairing mode. Connecting one device, then turn off bluetooth on that device, and then turn Bluetooth on the next device and pair it with that works. Then turn on Bluetooth on both devices, then it seems to work stable. However, after connecting 2 devices, the FP app keeps crashing again… To fix that, restart the Fairbuds. Feels like a well tested device :nerd_face:

1 Like

Do you by the way have the aptX PipeWire package (pipewire-codec-aptx) installed? It may be in a nonfree Debian repo. It’s in RPM Fushion on Fedora, so license wise it’s iffy.

You should see something like this. Or any of the other profiles of course.

Had similar issues on Ubuntu 22.04, fixed it installing Gstreamer Bad Plugins to enable aptX support. I used this resource online: https://devicetests.com/enable-ldac-aptx-bluetooth-ubuntu

The buds now work as BT audio device, but claim just to use A2DP Sink in settings.

Hope this helps.

On ubuntu 22.04. I cannot connect my Fairbud XL as headset. I tried the workaround @FGR mentioned but both methods ( gstreamer1.0-plugins-bad and pipewire) described on the site he linked did not work for me.

Via bluetoothctl on CLI I can add the XL to trusted devices and they are then listed as paired-devices. I turn them on and they connect via bluetoothctl but they are not listed as a headset No sound via bluetooth.

If I forget them as a bluetooth device and try to pair via system settings I can allow a bluetooth connection via GUI and it shows they are connected (it even shows the small headset symbol on the device details) but again no sound. If I turn them off and on again I can not use the GUI to make a connection since the button is not working.

What about the aptx software support? I don’t use Ubuntu, but maybe it’s something like that you need to install.

installed and enabled pipewire via (these instructions).

Name des Servers: PulseAudio (on PipeWire 1.0.0)
Version des Servers: 15.0.0

Can connect to the Fairbuds XL but only via CLI (via GUI settings didn’t work):

###$ bluetoothctl connect 9C:.....:ED
Attempting to connect to 9C:.....:ED
[CHG] Device 9C:.....:ED Connected: yes
Connection successful
###$ bluetoothctl info 9C:.....:ED
Device 9C:.....:ED (public)
	Name: Fairbuds XL
	Alias: Fairbuds XL
	Class: 0x00240418
	Icon: audio-headphones
	Paired: yes
	Trusted: yes
	Blocked: no
	Connected: yes
	LegacyPairing: no
	UUID: Vendor specific           (00001100-d102-...)
	UUID: Generic Access Profile    (00001800-0000-...)
	UUID: Generic Attribute Profile (00001801-0000-...)
	Modalias: bluetooth:v000Ap0000d0000

… but I cannot use them as audio output device.

Maybe try out Fedora? Ever since I switched to Fedora I have no issues anymore and I can just focus on work rather than fixing my own desktop :slight_smile:

1 Like

Change the operating system due to faulty headphones?!? nope. My system already worked wonderful with a pair of Marschall Monitor II ANC and a pair of Teufel Real Blue NC. So the problem is not the computer or the OS… which is why the Fairbuds XL are most probably (and sadly) going back.

I’m trying to say that it will work easier with maybe a different distribution. Of course it will work on Ubuntu as well, but since you’re struggling it may be worth considering to switch. The Fairbuds connect just fine on my Fedora system. No tinkering required.

1 Like

Can you connect the Fairbuds XL without problems on Ubuntu 22.04 ?
Could you please check your history which steps you did to get the connection? Was it only the Gstreamer Bad Plugins you had to install? My system already has them and I cannot get a connection.

One other thing I noticed yesterday was: when trying to connect via settings-GUI (Fairbuds already being paired and trusted) I open the details tab which shows the headphones symbol but as soon as I clicked on the button for connecting → the button does not move to show it is connecting and the funny thing is that the Fairbuds XL say “pairing mode” as if instead of connecting the headphones, the system sends the Fairbuds into pairing mode. Is this even possible? I thought pairing mode was only supposed to be initiated via the Fairbuds device and not via commands from extern.

Yes they work without issue after installing gstreamer1.0-plugins-bad and a reboot. Before that I just checked some stuff: pactl info for pulseaudio info and pipewire --version to check the compiled and linked versions of pipewire. Just to figure out what could have been the issue, but didn’t change anything.
lsb_release -d gives Description: Ubuntu 22.04.3 LTS
pactl info gives:

Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 32
Tile Size: 65472
User Name: [redacted]
Host Name: [redacted]
Server Name: pulseaudio
Server Version: 15.99.1
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: bluez_sink.9C_0C_35_60_86_A5.a2dp_sink
Default Source: [redacted]
Cookie: 2b54:272f

1 Like

I use the Fairbuds with Lubuntu. They connected right away and work just fine. I also installed gstreamer1.0-plugins-bad; best sound when using A2DP, codec aptX HD. I use PulseAudio.

If it helps anyone else, I gave up on trying to get the headphones to work with Ubuntu 22.04, and I just installed 23.10 from scratch (I was due for a refresh and upgrade anyway). So if you’re really struggling with this, that’s one option.