Fairbuds XL firmware update (V90)


already installed and tested it … the installation process worked by the first try, so the old issue that you need to try several time to install is resolved.

also I can confirm that the EQ settings are now held when the Fairbuds XL are rebooted or turned off

Now I’m really really happy with them … :slight_smile:


I’ve had now 3 firmware updates, I didn’t encounter this issue. Let’s hope it’s indeed resolved nonetheless.

1 Like

Everything works perfect since the update … I used them today since morning … :slight_smile: … I tried several times to reboot and also powered off and powered on again …

1 Like

Does anyone know of an EQ setting that works super well?

I generally have Amsterdam as the default but I’m always keen to use a setting that works to improve on the deficits.

this is my setting which I love and it’s for my Rock / Goth Rock music

1 Like

I have the Fairbuds XL and the new V90 update came out recently.
In the first attempt I had several failures until the app claimed that the update was successful.

Now the Fairbuds have been behaving strangely since then. Among other things, the start-up sound comes twice when I switch on the Fairbuds.

The most interesting thing, however, is that yesterday I got another message that there was a new update and it was the V90 version again.

Does anyone know this problem that the V90 update obviously cannot be installed successfully?

Best Regards


The updates aren’t idempotent. If you reinstall the app, it will push the same update again. I don’t experience these issues though about the startup sound.

It’s not specific to V90, but here’s my experience with the double start-up sound glitch.

Mine suffered with a double start-up sound after failures to update with V87. I then also thought there might have been clicks and pops and other glitch sounds at various times, but couldn’t be sure. I contacted support and they took them in for repair. Eventually (they lost them for a month), they decided they couldn’t repair them and so sent me a new replacement. So I believe that you’d be eligible for a replacement.

My new set did again have trouble with the V90 firmware update, but after several attempts the app claimed success. I haven’t had a repeat of the double start-up sound, so that’s progress, I guess.

after a few attempts, it finally worked. It seems that you sometimes need a lot of patience with the update process.
The previous update was reasonably problem-free, but now with version V90 it took a lot of patience and various failures.

Best Regards


Did it also fix the double start-up sound? It would be good to know if it did, just in case further updates suffer the same problems.

Maybe try a hard reset of the headset? In the documentation it’s described which long-press button (combination) is required to do that. I didn’t experience this bug. Also no issues with updates. I keep the update process in the foreground, maybe the app is paused when you minimise it and then the update fails.

Yes, double start sound is fixed too :slight_smile:

1 Like