External SSD not recognized anymore

Hi, I recently bought an external SSD (SanDisk Extreme). During the first few weeks it worked without any issue, but since last week the device is not recognized anymore by the phone. It is still working well with other devices. I’m using the same USB-C cable that I always used.
Is there anyway to find/solve the problem?

Thank you!

Welcome to the forum.
I’ve never connected an external drive via the usb port, so I can only imagine, have you tried another USB-C IF compatible cable?

Have you check the port on the phone for debris?

Can you use the cable to connect other devices to the phone maybe adb on a computer?

1 Like

I’ve never needed to connect a SSD but first thought is, after connecting the cable, go to Settings > Connected devices > USB and make sure the file transfer option is selected.


No, I have not tried another USB-C because the one that I am using was working well before and it is still working when I connect the SSD to my laptop, so I just assumed it is not a cable-related problem. I have checked for debris, and the port still works with other devices and when charging. The same cable can be used to connect the phone to the computer, and it works.

Hi, thanks for the reply. I cannot modify the USB settings since the device is not recognized. I can only modify the settings when the device is recognized by the phone. Right now it simply does not show up as a USB-connected device, while it was correctly recognized (and visible in the file explorer as an external device) a few days ago.
I was wondering about a possible power-related problem (the phone not being able to deliver enough power to the SSD via the USB-C). Could it be possible? If this is the case, what I do not understand is why it was working well a few days ago… Could it be related to the increased number of files on the SSD?

1 Like

Have you checked any power saving settings you may have Battery > Battery Saver : OFF

I think that’s unlikely.

However the power question might well be relevant. It might be worth trying to work through a self-powered hub or dock (if you don’t have one, try and borrow one or test in a shop, or get in touch with a local Angel who might be able to help). There are a number of topics in this forum on the subject of docks, and external discs, have a look round.

This certainly looks to me like a USB problem. Bear in mind, when looking into this, that the FP’s USB port, although USB-C, (physical socket) supports USB 2.0, not USB 3 as one might be led to expect from the physical format.

You state that the SSD is working with other devices (good!) What about the phone itself? Can you transfer data with a PC or MAC over the USB? I’m thinking there may be a problem with the port, even if it’s charging OK. Also that the phone connects OK to the computer, so I think we can rule out a problem with USB data port. That still leaves powering the SSD.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.