Ethernet over usb with the Fairphone5?

I tried connecting various usb-c to Ethernet dongles to my new Fairphone5 but they seem to not work.

This is a bit surprising as I read that usb-c docking stations function and that PostmarketOS has Ethernet over USB working on the FP5.

Is it maybe some setting in Android 13 that disables this function?

Welcome to the Fairphone community.

What does " seem to not work" mean exactly? Are they not recognized at all? Can’t you find the settings?

I tried two different dongles that work with other Android 11 & 12 phones. One seems to stay completely dead with no reaction on the connection lights or in Android at all and the other one does light up the ethernet connection lights but also no reaction Android side.

I suspect that feature might be disabled in the Android Linux kernel that ships on the Fairphone5?

Hello, Ethernet works fine on my FP5 with an Microsoft Surface USB LAN Adapter.

I tried a third adapter now and it is also not working.

A restart and a few other things later it suddenly started working :crazy_face:

1 Like

“Have you tried turning it off and on again?”

SCNR :nerd_face:

Have the same problem with the usb-c to ethernet function - tried Belkin and Dell adapter and a Enklen USB C Hub. FP5 only recognises somtimes the ethernet connection (icon in the info bar) but it is permanetly switching on and off. In most cases no connection will be established. Tried serveral usb settings and reboots…

Did anyone know, which adapter ist working properly? Thx.

Various Chinese brands, like Ugreen.

But you issue sounds more like an actual hardware defect if it works sometimes for a short amount of time.

Additional tested the Microsoft Surface USB-c LAN Adapter - this is working for the ethernet connection, but will not charge the phone simultaneously. Would be great if one hub would do that like the Enklen USB C Hub did for all other phones…