Errors during manual update process via fastboot

Hi Community!
After the failed attempt to update my FP2 with the Updater App to Fairphone OS version 21.05.0 yesterday (an error showed up during the process), my phone was stuck in the starting screen (Fairphone - powered by Android).
I tried a manual update via fastboot, followed all the instructions, but the update process keeps getting stuck at that point:

Proceeding to flash the device.

Sending ‘rpm’ (186 KB) OKAY [ 0.003s]
Writing ‘rpm’ OKAY [ 0.053s]
Finished. Total time: 0.094s
Sending ‘sbl1’ (274 KB) OKAY [ 0.012s]
Writing ‘sbl1’ OKAY [ 0.051s]
Finished. Total time: 0.089s
Sending ‘tz’ (334 KB) OKAY [ 0.316s]
Writing ‘tz’ OKAY [ 0.051s]
Finished. Total time: 0.414s
Sending ‘modem’ (57585 KB) FAILED (Write to device failed in SendBuffer() (Unknown error))
fastboot: error: Command failed

ERROR: Could not flash the modem partition on device XXX.

ERROR: Please unplug the phone, take the battery out, boot the device into
ERROR: fastboot mode, plug in the phone, and start this script again.
ERROR: (To get to fastboot mode, press Volume-Down and Power until the)
ERROR: (Fairphone logo appears.)

I managed to enter recovery mode (not TWRP) and according to that, my phone was still stuck with Fairphone OS 19.11.2. So I tried to reapply this system with a manual update via fastboot, downloaded the 19.11.2. ZIP files etc. but again, I can’t get past that point:

Sending ‘modem’ (57585 KB) FAILED (Write to device failed in SendBuffer() (Unknown error))
fastboot: error: Command failed

ERROR: Could not flash the modem partition on device XXX.

Does anyone have an idea how to succesfully install either the old or the new OS from here on, preferably without losing my data?

Thank you!

It may be helpful to know what operating system you use on your computer.

1 Like

Sure! it’s Windows 10.

Is it 20H1, 20H2 or 21H1?

Windows 10 Home - 2004 is my current system.

Just updated it to 21H1, but didn’t change the response I get during the update trial. Temporarily it got one step further to:

Sending sparse ‘system’ 1/4 (524284 KB)

but then it failed again. Now it’s stops again at “modem”.

Just a wild guess: does it improve when using a different data cable or usb port on your PC?
I think I remember earlier cases where users had problems on a USB 3 port but it worked with a USB 2 port (if your computer still has one that is).


Thank you! Actually it improved a little with a different cable, reaching one step further in the process. I already tried all 3 available USB ports, I think they are USB 3.0.
But still not finishing the update, unfortunately.

It is perhaps worth some more tries.

1 Like

Thank you - also for linking to the other threads, which I hadn’t found yet!
Still not giving up and trying for the 100th time or so. Sometimes it gets to “system 3/4” and I get the feeling that it improves after waiting a little before the next try…
Unforturtnately, I only have another Windows 8.1 computer at hand right now, which doesn’t find the fastboot device. But I hope I can try with other computers within the next days.

Right now, I’m too afraid to flash images manually as suggested here FP2 not rebooting after updating to 21 / Android 9 - #60 by Alex.A, as I have no idea what happens when it fails/I make a mistake etc.

Do you think the TWRP #twrpwoflashing could help me here?

Don’t think so as FPOS is installed via fastboot and fastboot mode is independent of running a recovery (i.e. the recovery type used).

1 Like

Finally my phone updated to 21.05.0!
I used TWRP as explained here #twrpwoflashing to access my phone data on the computer and save it there. (Doesn’t have anything to do with the update, but at least I felt more comfortable trying again, knowing my data is save).
Then I tried to flash the images manually as linked above - that also failed, but also didn’t do any harm.

At a random attempt to reinstall 19.11.2 manually, that eventually worked.

So, I dared to do the update to 21.05.0 with the fairphone updater again, it exactly went like @scribe writes here: FP2 not rebooting after updating to 21 / Android 9 - #15 by scribe

So, my phone runs smoothly on 21.05.0 for 2 hours now, all data still there. If you experience the same problems: Really just keep trying, try different cables, USB ports, computers if available - it was worth the patience! Feels like having a brand new phone right now after 5 years FP2 :wink:
Thank you for your support!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.