Enable Google Pay Wallet on Power Menu

Hi there,

I really like this feature that I used a lot on my previous phones, enabling to pay quickly with just a long press on power menu. That option seems to be absent from FP4, anyone has an idea if there’s a mod to enable it ?
Found this but it seems quite outdated and only relevant for Google Pixel devices

Paying works works without pressing a button. Or are you talking about something else?

It works without pressing a button, like just putting my unlocked phone on top of a paiement terminal ?
If so, did not know that, never tried ! Always assumed you had to open Pay app or the Wallet feature on power menu.
Anyway, how does it behave if you’ve got like 3 different credit cards ? I would not want any “default” credit card automatically selected when putting the phone on a terminal.

Usually it works, sometimes you have to unlock the phone. But I don’t know what happens if you have more than one payment option.

The Power Menu (sadly) no longer exists on Android 12, Google removed it. Similar features are now available when dragging down from the top of your screen.

I didn’t know about that, yet I’m running android 11.
Its weird it just seems like the feature is somehow disabled by FairphoneOS.

This is what I have with Android 11 on my Asus Zenfone:

Was enabled with this option in System → Gesture → Power Menu

It’s also available on my wife’s Google Pixel. I really think it’s a standard android 11 feature.
That’s why I wondered if there weren’t some magisk mod maybe to add it ?

1 Like

Oh oops, I thought Fairphone ran Android 12, my bad (I’m still on the FP3 myself).

Confusing to hear that you don’t get that screen though, it is indeed stock Android 11. Sorry, no clue what could be going on.

I had issues using Google Pay on my Fairphone 4. I am used to just putting my unlocked phone on the terminal without any open apps. Any chance to let my phone behave similarly?

It does behave the same way actually, what issue are you experiencing ?

1 Like

nothing happens. I don’t get an error message on the terminal or any kind of feedback on my phone.

if I hold something else with an NFC Tag close to my Phone, the phone works as intended. I set Google Pay as the standard Payment App

Is your device rooted ? Are your running FPOS or anything else ie idoé, /e/ OS ?

1 Like

oh sry. The device is not rooted and i am running FPOS.

Hmm weird, there shouldn’t be any issue :thinking:
Did you try to open the Pay app when paying ? If so does it work then ?

ill give it a try during lunch. after restarting the phone it worked just fine.

1 Like

I have the same problem on my FP4 running the Android 11 that came with the phone. I can only pay with Google Pay by opening the app and tapping on my card.
For comparison, on my previous phone, a Nokia 8.1 also running fairly stock Android 11, I could use Google Pay any time the phone was awake, including on the home screen. The Nokia also had the card picker in the power button menu, which is also missing on my FP4.