English

Email not working when I changed country & even when I returned!

I travelled recently from UK to France & as soon as I left the UK, I was unable to get emails on my FP1 (I received some just before departure).

I thought it might be my bloated battery problem as I’d been unable to get a new (Huawei) battery before leaving as perhaps it’s more work for the battery to get emails via a service that’s UK based when not in UK - I use GiffGaff, which uses the O2 network. I was able to access the internet when in France, so long as I was at campsites with a WiFi connection; & I also got Facebook notifications & could directly access FB; but try as I might, I could not get emails.

Once back in UK, I thought I’d get emails again. WHen I couldn’t do so, even with WiFi access, I assumed it was the bloated battery problem now having 2 weeks backlog of emails to load.

Back in Edinburgh, however, I put in the new battery which had arrived whilst I was away & still cannot get emails on my FP1. I have dealt with & deleted most of the backlog so there would just be a normal number of new emails to pull in, but it’s still not doing something it could do, even with bloated battery, before I went abroad!

I will ask on the GiffGaff website too, in case it is a network problem, but would love to know if anyone here has any ideas or suggestions.
Thanks so much, folks.

A worn battery cannot interfere with your phone downloading emails. If you can access other network services, there is something wrong with your mail account. Can you try to remove it from your phone and add it again after that?

1 Like

Could this also be a TLS issue?

3 Likes

@AndreaStC should probably try with an up-to-date email app like K-9 Mail or GMail rather than the preinstalled email app.

1 Like

I briefly read through K-9 Mail source code and found out that they enable TLS 1.2 on API16+ devices (as mentioned here).

@AndreaStC, try using K-9 Mail app for your mails, as the default mail application is too old and does not support modern encryption protocols.

1 Like

Many thanks, Stefan, Johannes & jnsp: I have now installed K-9 Mail.
Setting up my mail account, I’m getting an error I can’t resolve. It seems to be one others have had with K-9 (from looking at questions on their website) but I didn’t understand, from the response (… cause might be time set incorrectly on one side, expired certificate, or client rejected by Google for a random reason) what I should do.

The message on my FP1 is: "Authentication failed for [my email address] Update your server settings.

I had put in the server settings as they were before under the preinstalled email app. Rereading your responses re TLS, I wonder is there a problem that I used SSL/TLS as my security type?

Other account details are:
type of account ~ IMAP
IMAP server ~ host59.servers.prgn.misp.co.uk
Port ~ 993
IMAP path prefix ~ INBOX

I got the error message for these incoming settings & haven’t got as far as being able to input outgoing settings.

Many thanks again.

When reading the K9 issue tracker, it does indeed appear that some components to establish a secure connection with your mail server may not be present on the phone (servers differ in the details of the various components used for secure comms that they accept). Worryingly, there are reports that G-mail (presumably the app) also doesn’t connect - probably ruling that out as an alternative. I’m not sure whether there is a way around this.

Apologies for throwing in just a quick comment about TLS earlier, I didn’t have time to expand on it and hoped someone else would pick up on it (which they did; thanks guys!). For some background: there was a deadline for switching away from older crypto routines on June 30th, which has led to a lot of companies changing their server settings around that time. Unfortunately, it seems that we don’t have much experience here on the forum in working around the issues that this is causing in some cases.

1 Like

So, after all this, I thought I’d try the first suggestion of removing my mail account from my phone & adding it again.

When trying to add my mail account again:
~ to begin with, I had an error message that mentioned a peer problem, so I uninstalled K-9 Mail app;
~ then I again had an error message, still with incoming server details, saying it couldn’t connect to the server.

So, if this is to do with the switch away from older crypto routines, is there any way at all of getting emails again on my FP1, or am I just unfortunate with the particular hosting company for my mail account?

And perhaps going to another country, where no doubt O2 would have to “borrow” another connection as it were, is not relevant but it was simply a coincidence that I travelled on 1 July!?

Could you give us the address of the server? We can check which connection methods it accepts and whether this is indeed a TLS issue.

1 Like

I just checked the IMAP server mentioned above…
openssl s_client -tls1_2 -connect host59.servers.prgn.misp.co.uk:993 - works :white_check_mark:

openssl s_client -tls1 -connect host59.servers.prgn.misp.co.uk:993 Handshake failure :x:

So this is indeed a TLS problem and your provider has coincidentally turned off TLS 1.0 when you were traveling on 1 July. This is not surprising, as it is required to turn off TLS 1.0 from 1 July on to be PCI DSS compliant. Moving to a different mail provider that still supports TLS 1.0 probably won’t help you for long, as they will move to TLS 1.2+ sooner or later.

One thing we haven’t mentioned yet: K-9 Mail only supports TLS 1.2 from Android 4.4 on. As you’re still using Android 4.2.2, K-9 Mail can’t do much. There is an alpha version of Android 4.4 provided by Fairphone here, it will solve this particular problem, but might bring new problems.

2 Likes

Thanks so much for checking all that & I’m pondering what to do…
I’m thinking it’s time to get a FP2, though would love to keep the FP1 running as long as possible as well… It’s been teriffic & a delight, especially now I have a new (Huawei) battery in it for the first time in 4 years. :smile:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.