EFIDroid (multiboot) for the Fairphone 2

It’s now an official EFIDroid device, so you can use the official version of the app: https://play.google.com/store/apps/details?id=org.efidroid.efidroidmanager :slight_smile:


Thanks @z3ntu, this is awesome!

I just installed FP OS alongside my FP Open OS. Everything works great so far, the only issue I have is that my Settings App keeps crashing when I want to go to security settings to allow unknown sources and disable Google Play Services as Device Administrator.


Can you get a kmsg/dmesg log and/or logcat and send it to me via pastebin or something? Thanks.

If I knew what that was… I probably still couldn’t do it. Sorry! :blush:

adb shell dmesg > dmesg.txt and then upload the contents of the file dmesg.txt to pastebin :slight_smile:

1 Like

Was this solved? I’d like to try FP OS as a boot option besides FP Open OS, too - unfortunately I still need a (real) google system for a few apps that won’t work with microG (Car Sharing apps like car2go, multicity & drivenow, to be precise).

BTW this is my first post, I just got my Fairphone 2 a few days ago and I’m thrilled by all the tweaking options & to finally get rid of google (well, almost)! Thank you all for this great forum :slight_smile:


Welcome to the forum! You may want to introduce yourself here.

If you do the entire Level 5 from this guide you can get any app to work, although I’m not sure those apps really need all that. Did you install the NoGAPPS XPosed module to allow signature spoofing?

For me EFIDroid works great now since I got my cousin to allow unknown sources via ADB.

1 Like

No, @paulakreuzer, there are apps that still doesn’t work because not all Google Services Framework’s APIs have been implemented in microG (yet?). If the app’s main functionality rely on one of those, it won’t work. Fortunately, I think they are not numerous (at least, not the majority)

1 Like

Oh yeah, you are right. I was just thinking of “running” and not of “doing it’s purpose” when I said “get any app to work”.
Honest mistake as I never came in contact with such an app.


Thanks for those quick replies & good to hear that EFIDroid works well. As soon as I get a sd-card I’ll try this & eventually report here.

@paulakreuzer: I followed your walk-through (it’s great!), spoofed signature by Xposed module. All points in microG selftest are checked, but most carsharing-apps I tried crash at startup (tried car2go, multicity, carjump, mobility map – drivenow seems to work). Though in safetynet, ‘Response Validation’ fails, don’t know about that…

Try this module:

This App Will Run Without Google Play Services

1 Like

Hello. I had installed EFIDroid following your step-by-step example with fp2-sibon-16.12.0-ota-userdebug.zip archive. In TWRG I got a warning message concerning system partition, but install seems normally achieve. When I try to boot FP Open OS I had an endless reboot loop. Maybe you can give me some hints? Thank you for your work!

What “warning message”? And do you get access to adb during the reboot loops? If yes, please get the output of adb logcat and send it to me (pastebin or sth like that)

Ok. I’ll try soon and I will answer you.

I guess you mean the prompt asking you to give TWRP permission to modify the system partition. You have to allow it.

1 Like

Hi. TWRP message is : "Fail to unmount ‘/system’ (Invalid argument). When I try to boot into Open OS I see Fairphone logo, then back in EfiDroid. When I reboot in FPOS I can’t see device in ADB. Same behaviour with p2-sibon-16.09.0-ota-userdebug.zip

Press the “mount” button in the main menu and untick the system partition, then try again.

1 Like

System partition “is” unticked in TWRP and I can’t modify that. I can only thick “Mount system partition read-only”. I tried and I got several “Fail to unmount ‘/system’ (Invalid argument)” messages. I format dalvik and system cache but when I try to boot into Open OS I see Fairphone logo, then back again in EfiDroid.
Another thing, now I can’t power off my FP2, only reboot.
@paulakreuzer There is no prompt asking for permissions at all.

Uhm… I am out of ideas unfortunately…

I don’t know if this prompt is related to your issue, but if it is try rebooting from within TWRP, that usually triggers the prompt if you haven’t seen it yet.