EFIDroid (multiboot) for the Fairphone 2

Unfortunately i’ve run into the same Problem. I’ll see if I can try the solution proposed by z3ntu.

Did you download the full image, not only the incremental update?

Maybe you’re right. That was the problem. I had tried FP2-gms70-1.10.1-ota_from_open.zip from https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-downloads.html#download-releases. Suppose that was wrong.

I can just says that I myself didn’t have success with FP2-gms72-1.11.1-ota.zip

1 Like

Would be great to have also ubuntu-touch and Fairphone Open in dualboot with EFIDroid. Has someone experience?

It 100% doesn’t work as a second rom right now. It could maybe work, if you install EFIDroid (from Android), create a second rom (from Android), flash Ubuntu Touch (via recovery/fastboot), put the boot.img from Ubuntu Touch into the correct location (don’t know where right now), flash the boot.img from EFIDroid and then theoretically it could maybe work. :wink:

That would be my preferred way. What I tried is the following:

  • Installed EFIDroid in my FPOOS
  • Added another OS (ubuntu touch)
  • Rebooted in EFIDroid --> Fastboot --> ubuntu touch
  • And than maybe I used too much automatism with using the Magic Device Tool
    In the mdt script is one line
    fastboot format cache fastboot format userdata fastboot format system fastboot reboot-bootloader

and after that flashing the ubuntu touch recovery and boot image. Maybe that is the mistake.

Here you can see the mdt script.

Ubuntu Touch as a secondary rom isn’t supported yet but I meant that it might work as the primary rom.

Ah! Do you ha an idea how to try to configure it in EFIDroid?

That’s what I tried to write in EFIDroid (multiboot) for the Fairphone 2

Now I understand :flushed:

Following that guide I reached “Add a system to the new ROM”. But instead of “TWRP (internal)” it says “Recovery (internal)”.
If in the next window I select my newly created ROM it doesn’t boot into TWRP but reboots into EFIDroid.
Any ideas?

Yeah that’s because Ubuntu Touch overwrites the recovery with it’s own, CyanogenMod based one. I don’t think you really need it so please try flashing TWRP (for example from here : https://private.z3ntu.xyz/fairphone/TWRP_3.0.2-0.img) and continuing with the process.

1 Like

Thanks for your reply!
I’m sorry, I didn’t give you enough information. :blush:
I had started with FPOS 1.12.0 Beta. Then I had rooted it with boot-fairphone-FP2_gms75_BETA_1.12.0-su-eng-r292.img. Then (following your guide) I installed EFIDroid and within EFIDroid prepared the ROM FPOOS. Then I tried to restart and enter TWRP Recovery.
I may try to flash TWRP recovery as proposed.


I would like to dualboot Fairphone Open and Fairphone OS on a Fairphone 2.
I installed Fairphone Open as soon as I got the phone, it is now running version 17.01.
I would now like to add Fairphone OS with all those Google services via EFIDroid, I downloaded the latest FP2-gms75-1.12.0-ota.zip for that.

I followed the guide at https://z3ntu.github.io/2016/11/01/Install-and-configure-efidroid.html, but Install (Edit: at the TWRP stage) failed.
Since the first error in the console window was "E:Unable to mount ‘/system’ " I got around that by wiping system.

Install then still failed with:
Can’t install this package (Tue Feb 7 15:14:40 SGT 2017) over newer build (Tue Feb 21 12:38:37 CET 2017)
E:Error executing updater binary in zip "/external_sd/FP2-gms75-1.12.0-ota.zip’
Error flashing zip ‘/external_sd/FP2-gms75-1.12.0-ota.zip’

I tried the same thing with the older FP2-gms72-1.11.1-ota.zip and got the same Error, only with an older date (Dec 30 2016 vs. Feb 21 2017).

I have a TWRP backup of my Fairphone Open system, so anything goes as long as I would at least be able to restore the backup in the end.
Can something be done with the binary images of Fairphone OS via fastboot instead?
Or do I have to do it the other way around, restore the phone to the initial Fairphone OS and then add the Fairphone Open?
Or am I just doing something wrong?

Any help appreciated.

Are you sure that you have booted into TWRP by selecting the new rom and not the internal one?

1 Like

Well, I take the following steps according to the guide from the still working Fairphone Open OS:

  • Reboot
  • In EFIDroid right after rebooting, I select TWRP (Internal)
  • From the resulting OS list, I do not select “Android 5.1 (Internal)” but the newly created (empty) one, I named it “FP OS”
  • “Booting FP OS” appears
  • TWRP gets started, I swipe to allow modifications
  • Install
  • I select Micro SDcard for Storage
  • I select FP2-gms75-1.12.0-ota.zip
  • I turn off Zip file signature and swipe to Confirm Flash

… and Install fails giving the error I described.

Did I miss something important?
When I reboot from TWRP it asks “Install SuperSU?”. Is that related? Should I do that? Is that reversible just in case?

I updated the Fairphone Open OS to 17.02 and went through the Install procedure for the second OS again.
Interestingly, the newer date given with the error (Feb 21) stays the same, it is the day I bought and initially set up the phone.
Perhaps I just have to wait until one of the next Fairphone OS builds has a newer date than that :slight_smile: ?

If you are feeling adventurous, you can edit the file META-INF/com/google/android/updater-script and remove the first line and then flash that edited zip.

1 Like

Thank you, that indeed lets the Install succeed.
Unfortunately, the now installed Fairphone OS doesn’t boot, it just reboots to EFIDroid again.
I tried to Install it again with wiped system and all partitions unmounted like it was suggested here before, but no luck yet …

Edit: I tried the fastboot mode from EFIDroid for the second OS and flashed FP2-gms72-1.11.1-manual … same result (there seems to be no 1.12.0-manual yet).