Easy-Installer (adb) does not find my device

I am installing e/os on my FP3+ using Easy-Installer.

For more than 40 minutes, the Easy-Installer is searching my device. I started the easy-installer from the command line and redirected the output:
easy-installer > easy-installer.out &
There I see loops of

16:15:14.929 [JavaFX Application Thread] DEBUG ecorp.easy.installer.EasyInstaller -
OS name = Linux
Java Home = /snap/easy-installer/32/easy-installer-linux-x64
Current working dir = /tmp/hsperfdata_klt
ADB folder path = /snap/easy-installer/32/easy-installer-linux-x64/bin/adb/
16:15:15.015 [JavaFX Application Thread] DEBUG ecorp.easy.installer.EasyInstaller - language = de, country = CH
16:15:53.684 [JavaFX Application Thread] INFO  e.e.i.c.MainWindowController - loadSubScene(enableDevMode)
16:15:53.684 [JavaFX Application Thread] DEBUG e.e.i.c.MainWindowController - change view()
16:15:54.000 [JavaFX Application Thread] INFO  e.e.i.c.s.DeviceDetectedController - startDetection()
16:57:16.506 [Thread-1102] INFO  e.e.i.tasks.DeviceDetectionTask -   waiting
16:57:18.757 [JavaFX Application Thread] INFO  e.e.i.c.s.DeviceDetectedController - startDetection()
16:57:18.758 [Thread-1103] INFO  e.e.i.tasks.DeviceDetectionTask - runADBDevicesCmd(): 
16:57:18.758 [Thread-1103] DEBUG e.e.i.tasks.CommandExecutionTask - updateParameters(), Parameters = {1=devices, 2=-l}
16:57:18.758 [Thread-1103] DEBUG e.e.i.tasks.CommandExecutionTask - getFullCmd(), full command =  [/snap/easy-installer/32/easy-installer-linux-x64/bin/adb/adb, devices, -l]
16:57:18.762 [Thread-1103] DEBUG e.e.i.tasks.CommandExecutionTask - 
  (debug)List of devices attached
16:57:18.763 [Thread-1103] DEBUG e.e.i.tasks.CommandExecutionTask - Exit value = 0

16:57:18.763 [Thread-1103] DEBUG e.e.i.tasks.DeviceDetectionTask -  raw shell outputs = 

List of devices attached 
16:57:18.763 [Thread-1103] INFO  e.e.i.tasks.DeviceDetectionTask -   waiting

Also the command adb does not find anything:

~ adb devices -l         
List of devices attached

Any idea what I can do?

I forgot to mention:

  • USB debugging enabled
  • develop options enabled
  • file transfer via USB enabled

Isnt the easy installer using fastboot? If so adb commands cant work.

Thats often a bootloader/fastboot driver problem. How to update see here

1 Like

Thanks @yvmuell for your reply.
But what does fastboot mean?
I use the easy-installer on Tuxedo OS which is based on Ubuntu Linux 22.04.
I had installed the installer using

snap install easy-installer --channel=latest/beta

and afterwards, while the easy-installer was already searching

sudo apt-get install android-tools-adb android-tools-fastboot

Have you tried out if file transfer works when USB debugging is disabled? Maybe it’s a problem with the cable.

Other than that: does it change anything if you run sudo adb devices -l?

Btw, that’s the command the easy-installer uses at the very beginning to determine the phone model and which image files to download, before in fact it uses fastboot to actually flash them.

If you’re feeling adventurous, you could try this AppImage version of the easy-installer, maybe snap is the problem here.


Thanks @Ingo for offering help.

I use an USB4/Thunderbolt cable with which I connect normally my laptop a large screen. I thought the installatrion deserves the best acble in the house.
But with a standard USB A-C cable I have the same issue:
I can transfer files to the phone only when I switch off debugging.
(I tried this with the Plasma file browser Dolphin.)

adb returns an empty list, with or withouto sudo:

~ sudo adb devices -l
List of devices attached

What shall I do?

Hi @Ingo and @yvmuell ,
I found the reason why my FP3 could not be found.
The USB Guard of my Linux was the reason.
This helped:

~ usbguard list-devices
~ usbguard allow-device -p 54

I finally managed to install e/OS.
Another phone has been liberated from Google :smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.