English

/e/ Q is out for FP2

Hi,
I followed the upgrade doc to upgrade from pie (0.13) to 0.14 Q. Adb sideload with options wipe cache and wipe dalvik cache.
All went well. No big changes so far.

1 Like

Not really sure of what I meant by “it” either :wink:

So just did the upgrade to android 10 (/e/ 0.14 Q) just by sideloading the zip file.
Everything works fine so far… in fact as @chrisse said : no big changes so far…

2 Likes

Well, looking at what changed it doesn’t look “big” to me, too :wink:

  • UI changes across default applications.
  • MicroG version updated to v0.2.16.204713
  • Maps updated to v7.1.21.1.3613AA78.047032E6
  • OpenKeyChain updated to v5.5
  • security patches for January 2021
  • Misc LOS code updates

From what I understood, some Covid 19 apps stopped working as they were updated and the previous microG version was no longer compatible.

1 Like

You’ll find the major changes e.g. here (if you leave the information about UI changes out):

2 Likes

Hi,
I am experiencing issues since I upgraded to /e/ Q. Nothing new though: these are issues I had before but I got rid of since I installed /e/ pie from scratch. Now I am feeling like downgrading to check if it’s still better on pie. But on the upgrade document, I have read:

Warning : Downgrading Smartphones already on Android Q or LineageOS 17.x to Pie or from Pie OS to Oreo or Nougat can cause instability or at worst brick some devices.

Any experiences or advice? I guess the safest way to do it would be to install from scratch again?

Maybe. It seems that sometimes problem are caused by doing major release upgrades without doing a factory reset (in a perfect world the upgrade should always work - but sometimes it seems that the world is not perfect…).
Anyway - I’d always recommend doing a backup before an upgrade - so you can always go back…

Don’t know if it is android 10 issue, but so far I don’t experience any problem with /e/ 0.14 Q after upgrade from Pie… I’ll keep you in touch if it occurs on my phone.

@chrisse Do the downgrade worked and solved the problem (if have already did it…)?

I understand that Dark Mode is not implemented yet in individual apps (a known issue), but I just noticed there are some remaining issues with it in Settings, too:

2 Likes

I just flashed 0.14 Q on my FP2, without wiping (I’ve made a backup though). It worked flawlessly! I didn’t notice any problems yet. Thanks to the team!
But I couldn’t find the gesture navigation. Anyone has it on a FP2?

2 Likes

None of the new gesture options is available in /e/ independent of the phone model.

3 Likes

Not tried yet. I will wait and see how it goes this week.
Do you also have problems with notifications related to the calendar (every time it syncs, I see a notification “event notifications”… )?
As it is impossible to turn off the notifications for Calendar on /e/, I disabled the app and installed Etar instead. I still got the notifications at first, but I could turn them off.
I also disabled bliss, as I use Open Launcher. Less is more?

OK, seems wise.
No display problem so far… and yes I have sometimes “event notifications” but it seems completely random to me. If I remember right, I also have these strange notifications events with Pie.
I keep the standards /e/ apps for now, I want to try the system as proposed and honestly I’m quite happy with it right now, even Bliss Launcher is stable and do the job for me.

I have read somewhere (I think it was @Ingo) that it appears every 6 minutes! It’s not that disturbing, though. I just wondered if there was a way to make it stopped and found one, but I could live with the notifications.

I decided to do the same as you, but Bliss doesn’t work for me as I use a Calendar widget. That’s why I had to change the launcher. I still try to use the other system apps, but I see some limitations: not possible to disable notifications; not possible to backup sms in the message app even if it’s a QKSMS fork (I installed QKSMS to do a backup).

Yeah, and here is the corresponding issue: Unexpected "Event notifications" every 6min that disappears after 1s (#2049) · Issues · e / Backlog · GitLab

2 Likes

OK, I see. I just try to disable “Synchronisation notice” (not sure about that translation??) in Dax5 to see of it does something…

@chrisse : I use “todo agenda” as widget which works well with Bliss.

I thought that the widgets can only be displayed in the widget panel (swipe right), is this right? It’s good enough for many occasions, but I like mine on the “home” screen, so I can see it without checking it. Otherwise, I’m afraid I would forget stuff.

1 Like

Yes, you’re right… no widget on home screen in Bliss as far as I know… Sorry I thought that you were alright with the widget panel.

On Lineage OS 15.1 / 16 apps using vpn like TrackerControl don’t work. I tried TrackerControl on my second phone BQ Aquaris and it works, but I never got it working on my FP2. For more information read here: Not working on Lineage OS 15.1 / 16 · Issue #23 · OxfordHCC/tracker-control-android · GitHub
Anyone know if this is still not working on /e/ Q. Even my FP2 is on /e/ Pie i never tried it again cause it should the same as on Lineage OS 16.

I am using Tracker Control for my work profile on my FP2 (For my home profile, I am using Blokada). TC worked on /e/ 0.13 p, and works also on the new 0.14 q. At least it shows itself as “active”. So I guess it works? How could I know that it doesn’t work even though it’s active?

1 Like