/e/ Pie (Android 9) updates + feature tests

Thanks for testing and reporting this stuff!

I have a couple of questions:

  • play store apps like Spotify, do you just download the APK or are the provided in the /e/ store?
  • Do you have any experience with /e/ on updating a device? My main goal with going custom (lineage or /e/) is extending the software cycle. As i don’t expect timely updates from fairphone (not meant negative in any way).
  • My bank is online only bunq any idea if this will work with /e/ or is it to google play services dependant?

Thanks in advance

1 Like

At the moment I’m using Aurora Store installed from F-Droid to install apps. I don’t have much experience with /e/ so far. But there were some recent articles about /e/ saying that their app store isn’t too up-to-date (and uses Clearapk to get the files from where I don’t know if I can trust that).

But then, from what I understood they’ve just released version two of their store which I guess is meant to improve things. But then, I don’t intend to fully switch to /e/, so I stick with what I know (Google Play store via Aurora) :wink:

About updates of /e/ I don’t have enough experience to comment on that. And as I’m on the test channel, my update experience wouldn’t be representative of normal users anyway.

For specific app questions I think you should head over to the /e/ forum. There are the people who are experienced using /e/.
About banking apps: they have a howto at [HOWTO] Installing Banking Apps
But a forum search for “banking app” returns 50 hits, you may have to dig through those: https://community.e.foundation/search?q=banking%20app


In the past for FP2 there was at least one update per month (often more). At least one update per month is also planned for FP3:


TL;DR … a few thoughts about going back to Fairphone OS, if you just wanted to try /e/ temporarily …

  • Obligatory disclaimer: Be sure about your backup contents or syncing status. TWRP will not backup Internal Storage, as usual.
  • When restoring a TWRP backup, don’t restore every partition, probably stick to Boot, System Image, Vendor Image and Data .
  • If restoring doesn’t result in a booting OS, instead focus on getting a stock Fairphone OS running again somehow, either via installing a stock package via TWRP, or via flashing a stock image dump with fastboot, or via changing the A/B slot and do a factory reset (which should bring back the Fairphone OS version before the last update, if that slot was left untouched since then).
    I think when installing /e/ again, I might change the A/B slot beforehand to simply keep the current Fairphone OS I did get the backup from and install /e/ on the other slot.
  • Once the stock Fairphone OS is running, set the same unlock method you had before when you made your backup.
    I found that to be necessary to restore my data partition when I initially played around with TWRP backup and restore on the Fairphone 3.
  • Before restoring Data, make sure the stock Fairphone OS is updated to the same build your backup was made from.

If you’re interested in why …

I took /e/ for a quick spin yesterday just to see whether I could install it (which is really easy if you are used to fastboot already), and whether it seemed to work well out of the box (which it did), and with the bootloader left unlocked (which it did), and if MyPhoneExplorer would work to restore my contacts and messages and stuff (which worked), and whether I could go back to Fairphone OS … which then was, of course, an adventure, because I was feeling adventurous :slight_smile: .

Before installing /e/ I made a full backup in TWRP of my Fairphone OS A.0118 installation, I made a copy of my Internal Storage, and I synced what I could sync with MyPhoneExplorer.
I did backup all partitions in TWRP, because for installing /e/ you flash more partitions than this here recommends for a backup …

… so I wanted to be on the safe side and see how it goes.

When I was trying to get back to Fairphone OS I just restored all partitions and ended up in the OS not booting … an effect I know from the Fairphone 2, with the remedy on the Fairphone 2 being an install of the fitting OS build over the restored installation. But no can try, because I’ve seen no A.0118 stock package or stock image dump yet.

So I thought let’s see what’s there on the other slot … changed the slot … had to factory reset … and it happily booted A.0111 (as expected from the A/B update workings).
I set up the screen lock with the PIN matching to the one I used before I made the backup and then tried to only restore my data partition in TWRP, which failed with the beloved “extractTarFork() process ended with ERROR: 255” which translates to “Something went wrong, but I won’t tell you what exactly, because I don’t like you!”

So I updated the A.0111 to A.0118 via the Updater, which worked, and tried again to restore my data partition, successfully this time.
A.0118 booted and data was back. I copied Internal Storage back and synced my stuff over with MyPhoneExplorer and everything is just working fine as before, just on the other slot now.


How exactly? I’m asking because related questions came up in the /e/ forum: FP3 + encryption

1 Like

Since I use MyPhoneExplorer for syncing stuff to and from Android anyway, I also use it to copy the whole Internal Storage to the computer, because it can do that and because it can do that via WiFi, which is a lot faster than via USB.

Else I would simply connect the phone via USB to the computer when Android is running, enable data transfer, and copy everything to the computer a file manager (e.g. Explorer on a Windows computer) presents as “Internal Storage” on the phone (which requires MTP to work correctly on the computer side).

If the bootloader of the phone is unlocked already before any current backup attempt, it could also be done when TWRP is booted. TWRP enables MTP once it gets access to the data partition (i.e. once the user supplied the correct unlocking PIN/password/pattern equivalent for TWRP to decrypt the data partition), so Internal Storage can be copied via USB then, too.

1 Like

Doesn’t unlocking the bootloader wipe data?

When I was beta testing, unlocking with fastboot and not wiping the data led to a bootloop.
But then I didn’t try booting TWRP after unlock and before wipe, maybe that would have worked.


It does … but my bootloader is unlocked already.
Good point, I’ll edit to clarify.


Vendor security patch level on “dev” is “5 August 2018”?
Is that different on “test”?

No, it’s the same on test as well.

Hope it’s okay to pitch in here and add to your lists?

What works for me (in addition to Ingos list):

  • DB Navigator - there were issues on the FP1 & FP2 if no google services where available, so I had to downgrade the App)
  • Sonos
  • Several apps that use GPS to find “places nearby” - FP1 & FP2 same as DB Nav
  • Nextcloud (Client)
  • UniFi
  • Several bookkeeping/tax apps

Default apps I replaced:

  • Camera: The standard Camera app seemed very slow to me (compared to the default FP3 app) --> get the “Simple Camera” from F-Droid, works much better
  • Calendar --> if you integrate multiple webDAV calendars you might wanna consider “Simple Calendar” instead of the default; I couldn’t find a way to highlight the appointments in different colors (depending on which calendar it belonged to)
  • edit: please note: /e/ ships with a fork of DAVx integrated so you don’t need to install DAVx separately (I did and it crashed several times)

Slight issues:

  • Launcher: I couldn’t find a properly working launcher to replace the default /e/ “Bliss Starter” --> can’t get used to the default /e/ widgets
  • Bluetooth headset: I tried several, they all work; however small stuff like “Incoming call” -> “activate headset” usually means the phone recognizes the active headset (when paired before) and accepts the call. Half the time this accepts the call but the audio in and out is lost and stays lost even if you switch back to speakers -> hang up, call back

Other than that it works like a charm. Very happy here :slight_smile:


The test channel received an update today: 0.9-p-2020050352464-test-FP3

Now working: LiveDisplay :slight_smile:


Please define “properly working” … and which launchers did you try?

I tried Lawnchair, OpenLauncher, LaunchTime, Zim Launcher and the Fairphone 2 Launcher.
(F-Droid only)

Most crashed when I tried to add Widgets, customize any icon or when adding several icons together into a collection/box.

I’m using Lawnchair with Widgets and customised icon shape and size without a problem.

1 Like

It crashed every time I long-tap the screen > Widget > when I scroll down to select one.
I just realized it crashed everytime the scroll reached the “Simple Calendar widget”
I uninstalled SC and now it now it works, even after I reinstalled the same App… last time installed SC before Lawnchair.

Thank you! :slight_smile:

1 Like

Have the impression that /e/ consumes much less energy than the stock Rom.
Furthermore, I am astonished that GPS runs very good and finds connection within seconds.
Anyway, I am very happy with /e/

1 Like

I know that, after a real initial problem, my /e/ installation drains the battery a bit more than my stock installation did, but it’s currently not so much that I would go back to stock.

Hey there!
I think it’s really great, that we finally have a Google-free phone.
I have two really weird problems in WhatsAppt though and I don’t know whether they are related to each other:

  1. There is no sound in WhatsApp calls and the problem also occurs with headphones or a bluetooth headset. The microphone works, the other person can also hear me and I also can open other apps that play sound while having a WhatsApp call. Calls in other messenger apps like Telegram work fine.

  2. Also during a WhtasApp calls the screen turns black and usually I cannot switch it on anymore during the call, not with any key or going away from the proximity sensor. When the WhatsApp call ends the screen turns on again. Sometimes I can switch the screen once with a key, but if I try a second time it doesn’t work.

These problems only occur on /e/, on Stock Rom everything was fine. Anyone having an idea or has the same problem?

I have installed Magisk and Xposed, but I don’t think that it is related to the problem.

Have a look at this ticket, might be your 1.