/e/ os installation : fastboot do not detect my FP5

I try to flash my FP5 to install /e/ OS on my Windows 11 laptop.
I’ve downloaded ADB and Fastbook and try to run commands : “adb reboot bootloader” and “fastboot flashing unlock”. The adb command succeed, but the fastboot command keep display “< waiting for any device >”.
When I run “ADB devices” I see my FP. But when I run “fastbook devices” there is not device found.
I tried with several different USB wires with the same result.

In Windows devices manager, I see a device “Android” with a driver issue :
image

I tried to install Universal ADB Driver a described in this page https://support.fairphone.com/hc/en-us/articles/9425348234513-Connect-to-a-computer , I tried to install Google USB Driver from Télécharger le pilote USB Google  |  Android Studio  |  Android Developers but Windows device manager do not found any suited driver in the zip archive.

Does any one encounter the same issue ?
Any clue if I missing something ?

Thanks for the help,
Alexandre

Please have a look here

2 Likes

Thanks, I have finally carry out the installation of /e/ os by by booting on a Ubuntu USB Key and then run adb/fastbook .

1 Like

I have a related issue in ubuntu.

The phone is recognized by fastboot showing the correct serial but presents itself as a Google device on usb connection in fastboot mode.

lsusb returns 18d1:d00d Google Inc Xiaomi/Redmi2 (fastboot)
This is consistent when i connect the phone in bootloader/fastboot mode to a macbook.

The E os installation script refuses to proceed when ProductID doesn’t match FP5.

Any recommendations how to proceed?

I’m not /e/ user, but Xubuntu Linux, so i try look at your problem :wink:

From lsusb i have too this (also after updated usb.ids or hwdb.bin)

  • system booted + usb-debuging enabled:
    18d1:4ee7 Google Inc. Nexus/Pixel Device (charging + debug)

  • after adb reboot bootloader:
    18d1:d00d Google Inc. Xiaomi Mi/Redmi 2 (fastboot)

But for /e/ install script is output of lsusb irelevant,
because in flash_FP5_factory.sh is this detection

  • detect serial as first word from output:
    fastboot devices

  • check if in output of next command is: FP5
    fastboot -s your_detected_serial getvar product

  • i see this output:
    product: FP5

So you can try run this two fastboot command manualy and see what you have output
(for me work same with system-wide installed “fastboot” package and with fastboot from unpacked /e/ zip for FP5 in bin-linux-x86 subdirectory (where for manualy you must run "./fastboot … " - this fastboot binary use install script))

EDIT: for sure detection in script work when i run script and not only as descripted manualy way above i run script (after remove from it function to flash) and succesfully find my FP5 with output:

*** Fairphone 5 flashing script ***

INFO: The procedure will start soon. Please wait…
Note that this will detect and flash only on Fairphone 5 device.
INFO: You are using a Linux distribution.
INFO: Looking for connected device(s)…
INFO: One Fairphone 5 in fastboot mode found (serial number: here_is_my_fp5_serial).

2 Likes

Thank you so much for your reply.

After checking your test one by one I realized the problem was not in the phone but the fastboot in subdirectory of the installer files. After granting executable permissons to the scripts in the bin-linux-x86 subdirectory the script worked.

2 Likes

missing executable atribut on binary’s in bin-linux-x86 maybe depend on what tool you use to unpack, i use “7zip x IMG-e…zip” (now also try “unzip IMG-e…zip”) and executable atributs is present :slight_smile:

1 Like