English

/e/ OS - fastboot stuck in <waiting for any device>

First of all, I am quite the noob so please excuse if I make any rookie mistakes.

I bought a second hand Fairphone 3 with /e/ OS on it. After setting everything up and playing around with it I decided to go back to the Fairphone OS as some apps that are crucial to me are not working on /e/.

I followed this guide: Manage the bootloader of your FP3/FP3+ – Support

I currently have:
:white_check_mark: developer mode enabled
:white_check_mark: OEM setting enabled
:white_check_mark: USB debugging enabled
:white_check_mark: fastboot installed on Windows 10
:white_check_mark: adb installed on Windows 10
:white_check_mark: adb devices finds device (when FP3 turned on normally)
:white_check_mark: Fairphone 3 connected with USB-C cable to computer (it made a “ding” sound when I plugged it in)
:white_check_mark: Fairphone 3 started in Fastboot mode where it says in red “Device state - locked”

I got everything up until step 3.5 in the guide linked above.

When I try to enter fastboot oem unlock in the Git CMD (run as administrator) the feedback is .
However, nothing happens after this. Nothing new (still the fastboot mode screen) appears on the FP3. No error message on the terminal.

I spent hours and hours reading through forums but couln’t find anything that worked. Now I’ve got around 40 tabs open in my browser and still no solution. Any help is appreciated. Thanks in advance,
Tina

PS: feel free to answer in German, French or Spanish if you feel more comfortable in one of those languages.

EDIT: added point about adb devices

Soo luckily one of my IT friends who always have to save me jumped in. Apparently the driver on Windows was not up-to-date. The phone was recognised perfectly by Windows 10 when the Fairphone was in “normal mode” (adb devices worked also) but as soon as it was in Fastboot mode there was an issue. I had to follow step 5 of the prerequisites of this guide (the animated GIF) and Tadaaa, it worked! :partying_face: :partying_face: :partying_face:

2 Likes