E-mail said an update is ready but the phone's updater app doesn't

I’m I a little too quick on the draw or is there something amis with my updater app?

Try quitting the Fairphone Updater completely (holding home button and ‘swiping’ it from the list). Then reopen it. If he software update does not appear, just wait :smiley: I’ve been quitting and re-opening my Fairphone app all day and just now received the update. It’ll get to you, patience is the trick here :slight_smile:

Hi @Shagger, we created a pretty elaborate updater troubleshooting step plan here.

You can try those steps and see if something is amiss. Did you enable wifi? Otherwise nothing will happen anyway :blush:

Sometimes the update distribution system is a bit buggy, so patience, rebooting/following the steps in the tutorial linked above most of the times help.

I had to disable and enable WiFi for the updater app to see the update.

I took a bike ride around Longchamp for some laps. Then I tried Robin’s trick and it worked like a champ. Thanks Robin!

I didn’t know about t home button trick. I like that. Thanks again.