English

E-Mail attachments aren't sent anymore (VCF files causing problem)

mail
solved
attachment
Tags: #<Tag:0x00007fefc54e5a90> #<Tag:0x00007fefc54e5900> #<Tag:0x00007fefc54e5770>

#1

Dear community,

all of a sudden I am no longer able to send e-mail attachments from my FP2. The clients - K9-mail and Aquamail - pretend to do but the e-mail is received on my computer without any attachment.
Does anybody has an idea?

Thank you in advance!

Kristof


#2

Is there a “sent” folder of your K9-mail or Aquamail apps? Can you still see the attachments in this folder? Are the attachments there if you send them to other contacts?


#3

Thank you for your help.
Yes, there is a “sent” folder in K9-Mail, and the e-mail is stored there, together with its attachment.


#4

So I’m quite sure the email was sent out including the attachment. If that’s the case then the attachment must have been removed on its way to the recipient or it’s not correctly displayed on your computer.
Or did you lately install any additional app on your phone like an antivirus app?


#5

Also, some e-mail providers strip out attachments larger than a certain size or ones that have specific file extensions. If in doubt, try a simple text file - if that gets through then you at least know there is some specific filtering going on somewhere down the line.


#6

Problem solved.
I’ve found out that it is restricted to contact files (VCF (vCard) files).
I don’t know the way K9-Mail or Aqua Mail or Thunderbird (as the mail receiver) ist dealing with attached contact files. As a result however the e-mail arrives in Thunderbird without it. As a work-around you just have to rename the file’s extension (e.g. to TXT).

Thank you, Johannes and Volker for your help!


#7

I’ve just tried out and can confirm what you’ve found: it’s weird but Thunderbird seems to filter out vcf attachments.
When mail is still new/unread the attachment is shown:
grafik
Once you click on the e-mail the attachment information disappears:
grafik
I’ve checked source code of mail then and the vcf data is still there (on Ctrl+U).
grafik