"Download of message (No subject) from ___ was unsuccessful" - MMS download issues

Despite following all the setup instructions on the Fairphone website and Phone Coop (my network) website, I still cannot receive any MMS messages. The error message notification I get is:

Message not downloaded
Select to review the message and try again

then when I click on the message and then on Download, I get:

Download of message (No subject) from ___ was unsuccessful

I have tried repeating the instructions on here, with no success:

Anyone else had this and know how to fix it?


When you don’t receive MMS messages or don’t have 3G mobile internet it usually means your APN settings are wrong, or they are not there at all.

You can change them here:
Settings -> More… -> Mobile networks -> Access Point Names (APN) -> Tick your service provider

Usually you can get the correct APN settings from your provider’s website.
If you can’t find them then please ask them for it.

1 Like

Thanks, but I’ve already done that.

I tried all the options described here: http://www.thephone.coop/support/mobile/fairphone/
several times each.

If you have followed the guide and it’s still not working then I would suggest contacting the phone coop to make sure everything is setup correctly on your account and phone.

It sounds like a similar issue to this one that was resolved by calling the phone coop

Post back and let us know how you get on

1 Like

Hi Chris,

I contacted the Phone Coop on 13th December, and initially I got the same advice - they asked me to re-apply the APN settings again. But as they didn’t tell me to do anything differently from what I’d done before, it unsurprisingly didn’t change anything. So they are looking into it further, and I’ve not heard anything new yet. Fingers crossed for something in the new year…


Are you still having this issue?

If so could you try a different SIM card in your Fairphone? (Preferably from a different provider)
Maybe you can borrow a SIM card from your friends or family to test?

It took me a while to get round to it, but yes I have now tested it with a different SIM card from a friend, and that is not working either :worried:

Update - now that I have fiddled with the APN settings on that different SIM card (was supposed to be automatic but wasn’t), it IS working with my spare SIM (on giffgaff network). So it seem the problem is either with my SIM card, or with Fairphone’s compatibility with that SIM card. Thank you for the suggestion. I’ll try writing to my usual network (Phone Coop) now…

1 Like