Do Not Disturb is reversed for calls on FP4 (BUG?)

A few weeks back, I received my FP4, and I’m super happy. Last week I noticed something odd. I missed a lot of calls because my phone didn’t ring. Today I discovered why that is. As soon as the phone rings, DND switches on.

Manually disableing while ringing doesn’t change anything, it just doesn’t ring. On the other hand, when I manually enable DND, and then receive a call, it does ring. This definitely feels like a bug.

I’ve tried clearing all DND settings, turning them off and creating a new schedule. I also rebooted the device and tried a different dialer app, but nothing helps.

I’m on Android 11, build number FP4.FP3W.A.128.20220516.

Hi wout,
If this is still an issue, make sure to update to the most recent version of OS;
Settings > System > Advanced > System update.

Do you have any apps that might alter dnd in some way, like aides for concentration, quiet time etc?

Have you tried starting the phone in Safe mode just to see whether behaviour is “normal”?

3 Likes

Hi, in the meantime, the issue resolved itself. So I suspect it was a bug since I don’t have any apps interfering with dnd.

1 Like