Display replacement, now phone won't boot

The touchscreen on my FP2 started to become more and more insensitive during the past two months or so (letters along the left side of the keyboard not appearing when typing but appearing when phone turned 90°, then space bar not responding, then the comma producing a v, then etc.), so I bought a replacement module (yes, I know: support first…, but I’m not a patient person with certain things). Replacing following the ifixit how-to was a breeze, but now my phone won’t boot any more! I depress the power button once – nothing. I depress it twice – nothing. I keep it depressed for long, long, long… nothing but a short growl (actually a burring and vibrating) and then silence again.

Any suggestions what I might or should try? Thanks already.

I would first disassemble and assemble the display again.

No surprise, this shouldn’t do anything.

No surprise, this shouldn’t do anything either.

Better … and you can let the power button go after the vibration, this is how the phone acknowledges that it starts now … or at least tries to start.

Thanks, and yes, I know all that. I just went through it and recounted it to show that I had also «tried the impossible». And as for the last version, this is it exactly: the phone didn’t do anything after the vibration…

So I’d be grateful if you would now continue to the part where you tell me what to do. :wink:

And I might add: I also swapped the displays back again to the old display — and voilà, FP2 booting like a charm after the vibration.

Which OS version are you running? Check Settings -> System: About phone (should be near bottom of the settings screen). Tap on “Updater” there and see if it is at least or newer than Fairphone OS 17.07.

Looks like LineageOS.

It actually is LineageOS: 15.1-20180827-nightly-FP2.

Another try:
What is your modem (baseband) version
mine is: 4437.1-FP2-0-08
AFAIK the new display modules are not compatible with too old versions
you can simply update your baseband by installing the new version with TWRP

where do I find this information? In the settings I can’t see the term «modem» anywhere, and the search is inaccessible because the magnifying-glass icon is sitting in the corner, and although I can turn the phone so that the content changes from portrait format to landscape format (in both directions), the icon is not responding to touch in every position… gridlock!

look for baseband-version in “about phone” just above “kernel-version”

ok: it is 4275.1-FP2-0-09
on the other hand: useful and correct as this may be (I have no doubt it is), would this actually hinder the phone to boot? Or would it rather impede its functioning as an actual phone?

Of course I will update the modem - in a few minutes.

my guess is yes, because when I replaced my display, the fp support asked very very strong for that my phone is up to date (it was fpoos then, which gets also modem updates)

thanks again. I just downloaded the zip-file…

now wtf!? can’t even update the modem-zip in TWRP because the blue slider with the three white arrowheads won’t get moved all the way to the right side – that’s a non-functioning area in the touchscreen… try as much as I may, it can’t be done! No changing to landscape format in TWRP it seems…

the other chance is to install it via adb for your pc, but i cant tell you the correct commandline.
do you know some other fairphone with older display near by?

no, no idea about other FP users in the vicinity. But I did once do something with adb… must admit, however, that I have a horror doing anything with the terminal… I’ll have to give it a shot, don’t I? :persevere:

hm… not sure either what would be the correct procedure.
Here is what I tried on the terminal (MacOS). For the path I dragged the file to the terminal window:

(my computer):~ ahusi$ adb install /(path) /modem-latest.zip
adb server version (36) doesn’t match this client (39); killing…

  • daemon started successfully *
    Filename doesn’t end .apk: /(path)/modem-latest.zip

Maybe zip-files are unpopular with adb? Or did I screw up something with the necessary syntax? In the fog here!

Can anyone tell me how to proceed at this task? (step-by-step, that is…)

Not sure whether the above is going to be a problem, but other than that, install is only used to install apps when the system is running. Try starting the phone in recovery mode (i.e. TWRP), and then using adb sideload instead of adb install.

EDIT: You may need to set this up in TWRP as well, as explained here (point 3).

It might be this:
fastboot flash radio /(path) /modem-latest.zip
but I never did it this way before!

The modem wiki

is not helpful about it :frowning:

tried once again using the TWRP install, and after swiping «the blue slider with the three white arrowheads» without success a few times, I tried to drag my finger slightly upwards towards the right side border — and it caught! so the modem update was installed. So far so good…

The broadband version now is 4437.1-FP2-0-08.

(have to interrupt here, when back will try again with the new display.)

Good news: problem solved, everything running smoothly again, phone starts up, display shows everything and touchscreen functions everywhere.

Thanks a lot for your help and your time.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.