English

Display brightness takes up to 7 seconds to adjust to a readable level outside (Video included)

brightness
Tags: #<Tag:0x00007f1afb516248>

#1

Device
FP2 with OpenFP 16.11
Display settings: Adaptive Brightness on, brightness set to 50%

Core problem
It takes up to 7 seconds after pressing the power button to adjust to the display brightness settings to a readable brightness.

What happens?
Especially when I am outside and the sun is out, I turn on the phone, the screen is at like 10% brightness and then it takes up to 7 seconds until the brightness of the display is bright enough to do anything.

Video
This video has been made in the office, so it’s not exactly “outside conditions”. But the first couple of seconds, the screen is so dark you can’t see anything when you’re outside.

Since when does this happen?
I guess it was the update to 16.10, but I am not sure

Why is this a problem?
My phone is never ready for anyhting, unless i keep the display on. You know, it’s like:"Let me quickly look this up for…

20 - darkness

21 - 10%

22 - 10%

23 - 10%

24 - 20%

25 - 30%

26 - 40%

27 - ready for usage

What does this do to me mentally?
Put yourself into these situations:

  • Every time you want to accelerate in your car, it takes 7 seconds for it to even register that you pressed the pedal.
  • Every time you push the button on the remote of your TV, it takes 7 seconds to change the channel
  • Every morning you get to the counter of your favorite bakery you go:“Good Morning.” it takes 7 seconds for the sales person to lift their head to look at you and reply:“Good Morning, what may I serve you with?”
  • Every time you call your kids to the food table, they take a minute or so to even respond that they have heard you

How do these things make you feel? I feel annoyed. Very much so.

Often I don’t even take my phone out. I think “I can do that when I am inside”. You know, I don’t even want to activate my phone because I know I will have to wait “a long time” until I can see what’s happeneing.

It should be like:
“Gotta check this real quick”

  • whip out phone, press power button, unlock, check “that” real quick, press power button, put phone back in pocket

But now it is like:
"Gotta check this real qui…
1

2

3

4

5

6

7 okay, unlock…

What i tried

  • Re-Calibrate the proximity sensor, which i thought maybe has something to do with the brightness sensor - No change
  • I do use GravityBox and it does have a brightness settings enhancement, but It changes nothing. It does even say “activate only if the stock auto brightness works without problems”. It doesn’t so it makes sense to keep that off.
  • Played with the brightness settings. It does not matter if you have your brightness settings at 0 or 100%. It ALWAYS starts at a very dark state, going up in the last two to three seconds.
  • When I turn adaptive brightness off, it will go to the set brightness immediately
  • Read in the Forum, many problems with adaptive brightness but never quite the same. Also, no real solutions.

What I need
I need to find out how to fix this. In all my phones, this was something that was never an issue.


Fairphone Open 17.02.0 is now available
Fairphone Open 17.02.0 is now available
#2

I had this problem as well after updating to Fairphone OS 1.6.2:
https://forum.fairphone.com/t/fairphone-os-1-6-2-is-available/21257/47?u=jori&source_topic_id=24771

It has become better after the update to OS 1.10.1 but still isn’t completely fixed yet. But since it started to occur after an update, I hope that it will be fixed in a future update.


#3

I do have the same Problem.

Using Fairphone OS 1.10.1. I think I do have the issue since Fairphone OS 1.6.1.

Any solution would be great.

Stefan


#4

I confirm the issue on my FPOOS 16.11.0


#5

Same here, for quite some time actually. I try to unlock the screen while it’s getting brighter, it’s a good way to spend some of these 7 seconds!


#6

It takes indeed sometimes quite long before the screen has the appropriate level.
I have Open OS build 16.12.0


#7

With the last update (I’m on 16.12), the text is much brighter than before, so even if it still takes some time before the screen reaches the appropriate level, it is still readable inside. I’ll have to check outside in the sun (where is it by the way?), but it could be enough. If so, we could think this bug as an energy saver: every time you wake up the phone by accident, every time you just want to check the time and/or notifications, you use less energy!


#8

Same here. I’m on OpenFP as well. I don’t remember for how long my phone has been doing this, but it certainly feels like this behavior started well before update 16.10. Like @chrisse I have learned to swipe my code without seeing anything on the display, to gain a little time. Works most of the time but not always. I agree that this bug is rather annoying.


#9

I am having the same problem. And indeed, it is very annoying, as technorati describes it. The latest udpate to 1.12.0 unfortunately didn’t fix the problem :frowning:


Fairphone Open 17.02.0 is now available
#10

Experienced the same problem on FP Open OS. Found a workaround with Automate app (from apkmirror). I created my own flow (flowchart based script that reacts on events) that sets brightness to 100% on incoming calls and resets to auto adjust when phone idle. Later I noticed there is already the SmartCallBrightness flow in the Automate community ready for download (did not try this one, but should work).

It’s a workaround, but works like a charm.


#11

Thank you for the tip. I shall try this.


#12

I would appreciate a good solution for this, too. Thanks for the workaround suggestion.


#13

I use this APP and it works a treat!


#14

It does indeed! Thank you!


#15

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.