English

Dialer app does not work anymore (call not sent)

I have a rooted FP2 with an updated Open OS.
I am currently in Chile, with 1 Italian SIM card (Wind) and 1 Chilean SIM card (ENTEL). The dialer worked just fine until this morning with local (Chilean SIM) and receiving roaming calls (Italian SIM). I never called through roaming before.

Today I had to urgently call to Italy so I just started trying to call through both sims and I got “call not sent” errors.

I found out that roaming was not activated in the sims options, so I activated it but it still did not work.
Just to try something (stupid idea) i tried to change the network operator (in Cellular network settings) to both SIMs. This was a bad idea.

Now dialer does not work anymore. I click on contacts, number, or write numbers in the box but no way to start a call; if i touch the phone icon next to contacts the phone just does not react.

I tried to reset the network settings choosing “automatically detect network” but the situation did not improved.

Any suggestion? I still have to call Italy!!

Try going to Settings > Apps > All > Dialer and erase cache and data.

I tried but delete cache and delete data options are greyed and inactive; rebooting did not help.

Anyway now the app reacts and starts calling but I get Call not sent both for local and roaming calls.

If you only recently activated the option that the dialer should ask which SIM to chooose for the call, then maybe this workaround could help:
https://forum.fairphone.com/t/two-sim-cards-cant-make-receive-calls-when-both-are-turned-on-workaround-wait-5-seconds/12118?source_topic_id=23672

3 Likes

Thank you so much, this solved my problem!

2 Likes