"Decryption unsuccessful" after switching to LineageOS

Hey everyone,

I tried switching from Fairphone OS to LineageOS today. I was on the latest Fairphone OS version before (18.04.1, fairly certain about that) and encryption is enabled on my device.
I followed the instructions in the LineageOS installation guide and during the installation process, everything went well. I used the following software versions:

  • TWRP 3.2.1
  • lineage-14.1-20180425-nightly-FP2-signed.zip
  • Open GApps ARM 7.1 Mini

Like I said, the installation seemed to have gone fine, after rebooting the system I see the new LineageOS bootscreen and then I get asked for my unlock pattern.
However, when entering it the first time it just says “Wrong pattern” and after entering it a second time I get a screen saying something along the lines of "Decryption unsuccessful - The password you entered is correct, but unfortunately your data is corrupt."
It tells me to reset my phone to fix it, I pressed the reset-button, it took me back to TWRP and the script ran without errors. However, on the next reboot I get the exact same behaviour.

Fortunately I could restore the backup I created beforehand and now I’m back to Fairphone OS, but I’d still like to switch if possible. Does anyone have any ideas what this is about and how to fix it?

It may sound stupid, but if it is possible: Did you try to decrypt your FP2, then switch to Lineage and then encrypt it again on Lineage?

1 Like

Did you wiped your data in the process of switching from FP OS to Lineage OS, as indicated in the LOS installation guide? Doesn’t seem like so. Data formats (and signing keys) between any different OSes are, unfortunately, not compatible, so wiping is a requirement.

1 Like

Yes, I wiped the System, Cache and Data partitions as described in the installation guide.

It shouldn’t ask for your old pattern, then. Simply, it shouldn’t have it recorded, and the internal storage should be clean (and unencrypted).

Try to wipe your internal storage with the Wipe → Format Data option in TWRP, which removes encryption and ensures your data is deleted, as well.

Hmm… makes sense. Maybe I missed some warning/console output during the wipe-step. Using the Format Data option instead worked!

Thanks very much for your help :slight_smile:


My pleasure, :slight_smile:

Don’t forget to re-encrypt your data in Lineage OS afterwards!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.