Data not working on new FP4

I have a new FP4.
Everything’s working fine except no data.
Put sim in sim slot 1 as it doesn’t fit micro sim slot.
Phoned provider who say there’s nothing wrong .
Theres no option to turn data on in settings just an option to add a new sim
Help please

could you elaborate a bit here? Did you actually put it into the SD card slot? Does phone calls work?

please have a look here the SIM card needs Nano SIM size, you cant use a micro SIM card.


Thank you for responding
Its the same sim i used for previous phone, fairphone 3
Calls and wifi work fine
I’m an oldie and not very techie so not very good at using the correct terms

Ok so everything seem to be correctly inserted.

You may need to check the APN

Search the correct entries for your provider and compare to the entries under

Settings-Netowork/Internet-SIM Card-scroll down- Access point Names-click on whatever is there to open- check, change if needed- 3 bullets to save.

If all the same, click in the overview the 3 bullets to reset to default might help.

And just to exclude: mobile data are enabled?

Maybe change from 5G/4G/3G/2G to 4G/3G/2G


Thats where the problem starts, theres no way to access apn settings. I just get an image of a phone that says i need to use a new sim card
Can i add photos here to show you?

Ok so there seem to be no setting yet can you create one using the + in your second picture? Enter something and save just to see it works and then the provider specific settings.,

1 Like

Ok Filled in the utility warehouse settings and restarted but still not working

so this is your network provider, correct?

did you try to disable 5 G as suggested?

this suggests it does not even offer 5G?


May i get back to you later, viaitors due. I REALLY appreciate your help

The APN settings given on UW’s own website differ from those on the “tech tips” cited above.

Here are the settings published by the operator:

You’ll presumably need to change the “Name” value: “UW” instead of “uwclub”.

Also note that for MMS you’ll need to create a second APN called “UW MMS” as indicated.

1 Like

I actually think the name is quite irrelevant.

The other difference seem to be the use of user name and password (although is indicated optional, so actually no real difference), however whatever was tried so far, I would try the opposite.

have tried both lots of settings and restarted with no success

I would advice to re-discuss with your provider and to go over the settings with them to see if something is wrong, or the SIM maybe faulty (especially if older than 2 years)

1 Like

Thanks. I will do that. I really appreciate your trying. You helped me go forward a few more steps than before


UPDATE… thanks everybody for your help. after 3 calls to UW with 3 different suggestions a lovely fella talked me through a long list of turn on and turn offs and repeated refreshes and turn on turn offs that i would never have worked out and hey presto. data. not intuitive at all.
i really appreciate you all trying.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.