English

Data lost with update to 18.10.0 (FP open)

I just upgraded to 18.10, but that meant I lost all data and apps. Is there any way to sift through my now nearly empty storage for lost messages and media (photos, whatsapp messages, telegram messages)

do you mean the sdcard or the intern storage?

rollback your backup?

SD card is not recognised and internal storage seems empty.
Apologies for maybe asking the obvious, but how do I rollback the backup?
There was also a message that the data was corrupt…

Did you run into this issue? https://bugtracker.fairphone.com/project/fairphone-android-7/issue/66

1 Like

It seems the same issue, but the build is different: 18.10.0 sibon-280f64b0

But I would still need some pointers what to do next.
How to re-install Android 6 as suggested in the link?

I have this exact same problem. I have encryption on. I updated to Fairphone Open OS 18.10 today (from 18.04). At first it didn’t recognise my PIN, then second time it said data was corrupted.

This re-started into a clean install of the new OS.

I am quite worried. There were some photos and notes which weren’t yet backed up. Please advise on recovery.

Currently, the install is at the point of asking for my time-zone. I am leaving it there for a couple of hours whilst I decide what to do.

I am not concerned so much with bricking the phone at this stage (this is secondary). I am more concerned with getting the data back.

Thank you for advice,

Daniel

I have absolutely the same problem. Decryption not working after update. Correct password but corrupt data, suggests factory reset. WTF!. I also have OPEN OS and do not know how to go back to android 6. Factory Reset is NOT an option for me. please advise how to go back to latest working OPEN OS.

cheers,

Kai

As well as the problem of recoving my files, the phone is unusable in this state - part-way into an unwanted install-from-scratch procedure, and still on. This is causing some inconvenience for our project.

I tried to send a message to Support at Fairphone via their form. However, I can’t get the serial number from the battery without pulling it out. Is this safe to do?

I was looking at the instructions at https://support.fairphone.com/hc/en-us/articles/207914363-Manually-install-Fairphone-OS-for-the-Fairphone-2 but was unsure if installing (non-open) Fairphone OS was the correct thing to do?

  • Does it matter that it’s a different OS (not Fairphone Open OS)?

  • Will my files on the encrypted internal storage just become available somehow?

  • Is it better to access the file-system of the Fairphone remotely from a computer, to take copies of the important things?

I can reinstall the OS (open or otherwise) later but above all I would like to get at my own files, which are on the internal storage; and to be able to make and receive calls again.

Thank you in advance for advice,

Daniel

OK. I was able to go back to latest Open OS android 6… All internal data decrypted and accessible again. :sweat_smile:

Only for OpenOS
go to:

https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-downloads.html#download-releases

Download the file under Manual installation:

[fp2-sibon-18.04.1-manual.zip]

Boot the Fairphone 2 into the bootloader (also called fastboot mode) by pressing and holding the volume down button first and then pressing and holding power button as well

  • hold both buttons until the Fairphone logo appears (up to five seconds), then release them

while in the bootloader, the device will not display anything besides the regular Fairphone logo

connect phone to pc via usb

now execute the script from the file downloaded depending on operating system

flash-for-mac.command

or

flash-for-windows.bat

installed and reboot

et. voila…

cheers,

Kai

PS: I also send a mail to fairphone support…they now replied to check the bug tracker…

1 Like

Returning to Android 6 is essentially a manual install. The procedure is similar to that described in this Fairphone support article, except for Fairphone Open, you will need the manual install file (not switcher) from code.fairphone.com instead of the one linked there.

From the bug tracker issue linked above, it’s apparent that this only occurs on devices originally shipped with Android 5, and that disabling the screen lock before updating bypasses the problem.

Note that I do not work for Fairphone, and that I cannot test the instructions - I’m providing info from various sources for convenience only.

2 Likes

Many thanks to Kai26 and Johannes for the swift responses. Unfortunately, I think this has gone wrong for me. I fear I may have lost all data?

I followed Kai’s instructions. The script reports success on the Mac, but the Fairphone did not boot properly. It tries optimising apps one or two times, then there are messages like

“Unfortunately, the process android.process.acore has stopped”

“Unfortunately, the process android.process.media has stopped”

I ran the script again, and it was the same.

I tried booting in Safe Mode but it was just the same (though we get to the failures quicker, due to less optimising of apps).

After trying to boot to Safe Mode, I booted normally. after the error messages, the Fairphone eventually reached a set-up screen. I quickly ran through the set-up, and got to Android.

None of my apps are there, none of my text messages are there. At no point did it ask me for my PIN. The error messages repeat frequently and there are frequent reboots.

I assume I have inadvertently done a clean reboot? But even this did not work properly.

Does anyone know: can I still get at my original encrypted storage?

(I am impressed by the swift responses from the Forum. I am not impressed that Fairphone still pushes an update after it’s been known to cause this problem for several days …)

Thanks again,

Daniel

Same here. After manually installing the sibon-18.04 FP OS version, I can access my phone, but no encrypted folder to be found.

Kai: how did you decrypt the data? Was it detected somehow?

For me, everything worked as before after the return to 18.04 android 6 as described above. (internal storage accessible)

I was able to start android /unlock the phone with my previous gesture / pw.

It still said “phone ecrypted” in settings /security (android 6, version 18.04).

I then switched to no password/gesture and successfully repeated the android 7 update.

Now my 18.10. (android 7) works fine. password/ lock screen re-enabled afterwards. says “encrypted” in andoid 7 settings /security as well.

cheers,

Kai

1 Like

Judging by

I assume you powered down the phone when you got the data corruption/reset prompt, rather than continuing?

@ Johannes:

Exactly. I assumed that saying yes to “factory reset” at this prompt would result in the loss of my internal data storage. I thought this would be a point of no return…

I powered it down. First I tried unsuccessfully to flash various old OPEN OS zip builds via TWRP recovery and the external SD (was not possible)…than I read about successful rollback to the regular Fairphone 2 OS with the same bug:

https://bugtracker.fairphone.com/project/fairphone-android-7/issue/66

so I tried this procedure via bootloader mode and it worked also with OPEN OS, as described above.

cheers,

Kai

PS:
by the way, Fairphone should really warn/advise the people to turn passwords/gestures off before doing the update (or solve the bug)…as you are still pushing the android 7 update more and more people will get this bug and maybe as a result lose their data ! took me a lot of time and nerves today

1 Like

Hi.
so, same problem here. But: I think I had not enabled the USB debugging mode.
Running Linux, have not reset the phone yet.
the ‘fastboot devices’ seeems to detect the phone, but executing the shell (manual flashing script 18.04.1) seems to be stopping at ‘validation complete’.

Just for fun, I tried the command ‘fastboot continue’, which stops at ‘waiting for device’

Any advice?

/Edit: sudo ./flash-for-unix.sh did it. Simple as always.

Hello,

I do have a differnt problem, but it is connected to dataloss with the new android.

When I upgraded to the new FPOS18.10 all my contacts were lost. The same happened, when the operation system changed from android 5 to android 6. This is really annoying. All apps manage to transfer their data, like SMS conversations, but the standard app contacts does not work. After the update the only contacts left were the ones from telegram, because telegram obviously safes them on their own server and synchronises them whith the phone automatically.
Luckily I manged to get most of my contacts back from an older update with myphone explorer. But, now that I have synchronized contacts, all the telegram contact details do not appear in the contact list before. This is crazy, the only thing working does not work any more.
Does anyone have a similar problem with the update? And does anyone have an idea how to get the telegram-contact details back into the contacts app? There is even a “synchronize accounts” option in the contacts app, but when I sync, nothing changes, even though it confirms the synchronization.
At the moment I am completely lost, because the error seems really random.

I’m getting the impression I let the clean-install (initiated by the faulty upgrade process) go too far, and I probably can’t recover my data. Also, the phone is unusable due to the errors and rebooting.

I will probably do a factory reset and try a clean install of an OS of some sort.

I won’t install Fairphone Open OS. As a result of this loss of time and data, I have lost confidence in Fairphone Open OS.

Daniel