Data connection failure on EE UK after FP3 Update 901.4.A.0019.1

Thought it may be worth having a specific topic for this as it’s becoming clear that this is an issue in the topic

If a mod thinks it ‘wise’ then maybe relevant posts in those topics can be merged here.
That seems done so thanks

I can confirm that I have this issue on EE in the UK

@KoNu @HPat

Unsure if related to the update, but my fairphone 3 randomly stopped downloading data over mobile networks (noticed Saturday 17th December). I think it happened after I downloaded a subsequent Android/ fairphone security patch and restarted. I seem to be able to upload data/ send social media messages, but browser/ data downloads state there is no network connection.

Network: EE

Model: fairphone 3

Attempts to fix:

  • network settings resets
  • SIM tried in both slots
  • EE tech support phone reset
  • different locations inside and outside
  • no reported outages in region
  • manual network override and reselection of EE/ automatic
  • factory reset of handset

Any support to remedy would be welcome.

Hi and welcome to the forum.

Please reboot the phone, there is another post which I will try and find.

Hi amoun, by reboot do you mean turn it on and off?

I have done this many times over the course of my troubleshooting prior to today and through today.

If there is another process I am missing, please let me know!


Yes that is what I meant, sadly it hasn’t been that simple for you.

You may want to try updating the APN settings.

Do you have just the one SIM and do you have a PIN on in it?

There are many posts on resetting the APN, but I’ve never had to do it.

1 Like

Thanks I have followed up on another forum.
I don’t think there is a pin associated with the sim.
I have reset the APN to default settings but no luck.

Thanks for trying to help.

1 Like

I have the same issue. Also with EE. No mobile data after the most recent software update. Tried multiple restarts, APN updates, switching on/off mobile data, re-inserting SIM card. Still not working. Very frustrating. Basically a dead phone. Not happy at all.

I put my sim in my 2017 Samsung A3 which I switched from a month ago. All works just fine, so clearly a phone-related mismatch. Fairphone are yet to get back to me.

Hi and welcome to the forum

I have created this new topic to deal with this issue on EE in the UK

1 Like

I moved all EE parts here, else we will have a split mess over 3 topics


Thank you. I will switch back to the fairphone again after Christmas to troubleshoot. I have plans over the next few days that require data.

1 Like

I’m having the same issue. FP3, EE UK network. Installed security patch yesterday and when I went out this evening I realised my data wasn’t working.
Is there an easy way to uninstall this?

I’m also having same issue. Have spent hours with EE support trying to resolve. SIM works fine in other phones and other SIMs from other networks work fine in the Fairphone. Have ended up buying a new phone to get data back. Factory reset fairphone, still doesn’t work.

Does the problem also occur if you use 3G?

It did for me. No data downloads possible at all but sending whatsapp and fb messenger messages seemed to work fine.

1 Like

Sadly there is no convenient or slightly inconvenient way of downgrading the OS

You may like to open a support ticket with Fairphone officially and draw their attention to this topic.

1 Like

Thank you all for sharing your experience. If you are affected by this issue and haven’t already done this, submit a ticket. This helps us with prioritizing and you’ll be personally notified if there are progress updates.


Also got this exact same problem. Fairphone 3+, UK EE, software update, no longer downloading data from my mobile network. Tried a slew of troubleshooting fixes, including but not limited to a factory reset and backup restore, which messed up a number of other unrelated things. So, good to know all that was pointless.

1 Like

Thank you for the link to raise a ticket @Yasen_Tomov, I too am having an issue with data connection after the last security patch update from last week.

I’ll follow up with FP support.


I have the same problem after every update since Android 11. The workaround is setting Network type to 2G, reboot and after that reset to 4G/3G/2G.