Data connection dropping - Belgium FP3

My LTE data connection disappears at random while walking around.
Full perfect signal, then nothing, than back to full perfect signal. Nothing in between. I’ve been trying to see if there is a correlation with specific locations etc. but nothing clear so far.

Has anyone else noticed this with their Fairphone 3 or with their Fairphone 3 on Mobile Vikings Belgium, or on the Belgium Orange network (Mobile vikings runs off this)?

1 Like

I’m experiencing the exact same problem. I feel like the problem has been getting more severe in the past months and especially since I upgraded to Android 10.

Have you managed to fix it in the meantime?

1 Like

Unfortunately not, the issues persists. Are you using the Belgium Orange network or another one?

1 Like

I’m also experiencing problems with this. Extremely annoying.
FP3+ on Belgian Mobile Vikings network.
The past 2 months I’ve had to travel a bit and strangely enough in France (all of Eastern and Western France), Spain (Catalonia and Ibiza) and Iceland there are no such issues.

1 Like

I was browsing through APN setup and other network settings, and disabling “Enhanced 4G LTE Mode” seems to have solved my issue.
Settings → Network & internet → Mobile network → Advanced → Enhanced 4G LTE Mode

Ever since I disabled it yesterday it has run stable, no long-term results yet but you might give it a try.

Good luck!


I had the exact same problem, and disabling enhanced 4G LTE mode didn’t work either. However, I did a factory reset, and instead of manually entering the APN settings, downloaded the Mobile Vikings app over WiFi, after which configuration happened automatically. No more data drops since then!


I don’t know this app but the important thing certainly is to have APN settings up to date. Personally I’d rather get the values from the provider.
While disabling LTE may work in some cases I’d advise checking the APN settings anyway. That means finding them on the network operator’s web site (or relying on some app to do it for you, not so much my style :wink: )

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.