Custom TWRP 3.2.3 to decrypt Android 8/9 encryption

I also tried the version from @chrmhoffmann, which takes a long time to boot. It at least asks for a decryption pin, but I’m not able to decrypt data (“failed to decrypt data”), too bad :-/.

As I need a working FP2 I cannot try myself. Therefore again to make it clear to me:

Does LOS 16.1. dispose of an own recovery like Google Android? If so, it is clear that I cannot back-up with this recovery but it would be possible to encrypt and to reboot encrypted phone.

If so, could I wipe on my phone everything of existing encrypted LOS 15.1 and format data partition with ext4 and install then via adb without TWRP LOS 16.1.?
If I then encrypt this 16.1. it should reboot.
Of course I have no backups via TWRP but I could live with this situation as mails, calendar and contacts are safe on the server of my provider.

Did anyone try?


It is not mandatory to have TWRP which supports encryption for normal workflows, like: install Lineage 16, upgrade from 15.1 to 16, upgrade from one nightly build of 16 to another one. This can be done without TWRP decryption support.
a) Install Lineage 16 and upgrading from 15.1: can be done through “adb sideload” or from SD card, or I think from /cache - if that’s big enough (never tried myself).
b) Updating from one nightly build to the next: can be done through the Lineage Updater and does not require a recovery that can decrypt - if this does not work, it’s a bug in either FP2 lineage or twrp.

What cannot be done without TWRP with decryption:
a) access and backup data from twrp
b) store a downloaded lineage zip and install it (when downloaded through browser).

PS1: What apparently also does not work at all (nothing to do with twrp) is upgrading from 14.1->15.1->16 with an ecrypted data partition.
PS2: Yes, there’s also a normal “lineage” recovery (but lineage does not deliver them through download afaik). This lineage recovery does not support encryption, but it does support the above workflows. It can be compiled from the lineage / android sources. If someone wants that, I can build it and upload it.


Many thanks for the detailed answer.

So i have to format my encrypted 15.1. data partition and to install 16.1 nightly via ADB. Of course data are lost. Then, as far as i understood, i can encrypt 16.1. Updates for 16.1 can be installed via LOS-updater. Also the question is, whether at least the apps can be backed-up via ADB. Did it in the past under Ubuntu with “adb backup -apk…”

For me it is not mandatory as i could use ADB in case i have to go back to a fresh install.

As travelling need my phone this week, but would try next week and report if there is no better solution in the meantime.

I actually do not know. What I was told was that if you have encrypted with 14.1 and then go to 15.1 and then to 16 it does not work.

When you start from scratch in 15.1 and go to 16, this (I think) should work…


PS: I would try to save my apps with something like titanium backup (if there’s anything really important that is not saved to the cloud) and then just try.

in this new topic two users report that an install with a previously encrypted data partiton worked well.

I erased the encryption before installing Los16 however if I want to restore now my data partition with TWRP, android starts an encryption process when booting…

I’ve removed encryption and ‘convinced’ Android not to start encryption process at boot like described here: Lineage-16.0 (Android Pie) Beta


gonna try this! thanks a lot for this hint!

After updating to current signed/official LOS 16 versión, twrp’s decryption is no longer working for me either…

Will this fix the TWRP decrypt problem on LOS 16 ?

1 Like

Amazing! It worked! Thanks a lot!

No. Not related.


1 Like

A post was merged into an existing topic: TWRP 3.3.0-0 can’t decrypt Android 7/8/9 encryption

Thanks. May sound silly but my problem is to type the “_” I cannot see in TWRP what i type because it shows only stars. In Android I can see the text at least for a second. Is there any possibility to show the password?

There’s no setting for this.
You will have to watch what you type, the “keys” get darker for a moment when you tap them (lowlighted?).

Did some tests in the TWRP- terminal. There my problem was obvious as I can see what I type. The small figures on the keyboard and my big fingers do not work well together :wink:
Anyway, I am sure that after sufficient testing I inserted: default_password but it did not work.
One reason could be that I flashed 3.2.3 over 3.3.0. Will format my phone again this afternoon and do a clean install.

This shouldn’t cause any problem in the case of TWRP, don’t worry.

Users have previously reported that trying to decrypt data in the custom 3.2.3 TWRP works randomly, not in every case. No clue why this happens for now.


Whereas …

What’s the status currently? Have you encrypted with or without a password?

Not likely (as in: I want to outright say “No.” but I’m too cautious :slight_smile: ).

With password. But it is not accepted.

Then “default_password” will not work, because you encrypted with a password.

The custom TWRP 3.2.3 given in this topic as of now may or may not decrypt Android 8/9 encryption with your password.
I’ve seen it working sometimes with my password, but most times it failed …

And TWRP 3.3.0-0 as of now will not decrypt any encryption on the Fairphone 2.