Corrupted SD card

Hi everybody,

I just bought a 32 GB. Initially it seemed to work just fine, but almost every time I turn my phone off and back on, the SD card is recognized as being corrupted, which means everything I put on it can’t be recovered.
EDIT: I’ve formatted it numerous times and it doesn’t change the problem. (End EDIT)

This is exactly the same problem whether I put it as external or internal storage.

I hope someone can help me.

Love you people <3

Assuming that you have no data on the SD card that needs to be saved.
I would suggest that you format the SD card.
Go to ‘Settings’
Go to ‘Storage’
Go to ‘sdcard1’, it could be that the SD card has a different name. You need the ‘Portable storage’
Tap on the three dots in the right upper corner of the display
Go to ‘Storage settings’
Go to ‘Format’
and follow instructions. (As there is data on my SD card, I can’t go further).
Perhaps this will help.

1 Like

Yep sry I forgot to give this info:
I’ve already tried formatting the SD card, and the problem remains

1 Like

I hope someone here will have a good idea for a solution.
But I’m afraid I can only give the advice to give the SD card back to the reseller where you bought it or to replace it there.
I do have the same problem with a 32GB SD card. It also works in about half the cases and the rest of the cases the FP2 claims after a reboot that it’s corrupt. I’ve also formatted it several times, tried it in various FP2 devices and with different operating systems. So it seems to be a problem with the SD card…
When searching for a compatible SD card you might have a look here:


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.