English

Constant App Crashes, Reboots, Unresponsiveness

Dear all,

I’ve had my FP2 for quite a while now, since Feb 2016, so it’s not the newest anymore. For about 6 months, I’ve been having more and more trouble with it. I currently run FP OpenOS (19.11.2) with OpenGApps pico and a mix of F-Droid and Google Play Store apps. The phone is rooted but not encrypted. I have one SIM card and one SD Card in the phone.

Problems I’m having:

  • Apps regularly crash, some almost with every use. Sometimes immediately, sometimes after a few minutes. I don’t think there’s a single app that doesn’t crash, so it doesn’t seem to be connected to specific apps.
  • The camera is very unreliable (OpenCamera, upgraded back camera module). Particularly videos are hit or miss, sometimes it doesn’t start recording at all, sometimes the app crashes when I press stop recording at the end of a video, sometimes I press stop recording and then get an Error message. Sometimes I am successful in recording and saving the video, but then when I try to watch it, the image freezes after 5 seconds (sound continues to play though). The only consistent pattern I can discover is that in 9 out of 10 cases, SOMETHING goes wrong, but it isn’t always the same thing.
  • Watching videos is also troublesome when they are sent via Threema or Signal. Here the apps either crash when I try to watch a video or the image stops moving after 5 seconds and the sound continues. Sometimes it helps to save the video to Piktures (my gallery app) first and watch from there, but that only works about 50% of the time. Otherwise - same thing, image freezes, sound continues or the app crashes altogether.
  • If apps don’t crash, the phone often (multiple times a day) just becomes unresponsive altogether. The screen stays on but doesn’t respond anymore and also doesn’t turn off after several minutes, so I am forced to hold the power button for 12 seconds to reboot the phone.
  • The phone reboots randomly and frequently - at least daily, some days up to 10-15 times.

You see, altogether: my phone doesn’t really work anymore at the moment.

What I’ve tried so far:

  • I was still on Android 6 for a long time - all of the above problems happened there already - and updated to Android 7 about a month ago in hopes of solving these problems.
  • The update did not go very smoothly. I first followed the instructions here, as I have always done (usually successfully). In the process, though, I agreed to install the TWRP App and with that apparently wiped TWRP altogether. I then reinstalled TWRP via Fastboot and did a manual install according to these instructions.
  • Somewhere in that process, I lost all of my data from the phone. It was technically backed up with Titanium Backup Pro, but the restore process didn’t really work - that app, too, kept freezing or crashing during the restore process, so that some apps and data were restored, others only incompletely, others not at all. I restarted the restore process multiple times, but every time it would crash/freeze again somewhere during the process.
  • I eventually gave up on restoring from Titanium Backup and did a factory reset in Android 7. After that, I reinstalled all of my apps manually from F-Droid/Play Store. The only “old data” left on my phone now is that which is on the SD card (photos/videos, OSMAnd maps, contacts, etc.). Everything else was installed newly.

After that, the problems were better for about 2 days, then the crashes, reboots and unresponsiveness started up again and have become progressively worse. I’ve tried clearing the cache, that doesn’t help either.

I had really hoped that doing a factory reset and reinstalling things manually would take care of the problem, but it hasn’t. I’ve run out of ideas for where to look for the problem or how to resolve it.

What about you guys: any ideas what could be causing these problems? Is there some kind of system “below” the operating system (the SOC, the kernel…?) where there could be a problem and is it possible to do anything about that as a user? Are there logs anywhere to be found to explain the constant app crashes, reboots, freezes, etc.?

I really like my phone and I was really hoping to use it for longer still, but in this state, it is starting to really be unusable…

Thanks in advance for reading this far and helping me out with ideas!
-Emmy

I totally understand that you can’t use your FP2 in that state as a daily driver.

One idea I have:
As FP OpenOS is still based on Android 7, I’d recommend you to try another OS - e.g. LineageOS since Google won’t provide any further security updates for Android 7 since nov. '19
To get your FP3 rooted under LOS, you have to install Magisk
As you still have your Titanium Backups, you could try to recover all your apps with LineageOS again…
I don’t know if this solves your issues but I think it’s worth a try :slight_smile:

Hi, @HolosericaCaligo,

Thanks for your tip. That’s probably worth a try, though I’m going to wait a little longer and see if others have further ideas that I might still try before a new install. But I think before I install FPOpen again, I would indeed give LineageOS a try.

A quick question to the instructions link you sent - am I correct in assuming that I can skip the first step (Installing a custom recovery using fastboot) since the phone already has TWRP and can go straight to step 2 (Installing Lineage OS from recovery)?

Thanks!
Emmy

Check your TWRP version and compare to the known working versions. Some TWRP versions do not work as good as others.

So after researching LineageOS a bit, I decided to give it a try. Had a little bit of trouble figuring out the installation process, but eventually I got it to work. Now I’m reinstalling my apps - from scratch again…I figured, if I’m moving up 3 major releases of Android, it might not be a bad idea to do a fairly clean install. So far so good!

3 Likes

Hmmm…It’s been two days and slowly the problems are starting up again. I’ve had one or two spontaneous reboots, the phone freezes periodically and is unresponsive, a few apps have crashed and closed. It’s not as bad (yet) as it was the last time, but last time, too, it got worse over time.

Does anyone have any idea where these problems could be coming from? Seems like it’s neither related to specific apps nor to the operating system (given that I’ve now had the same problems with FP Open both on Android 6 and 7, and now with LineageOS 17.1…), but at least to me as an amateur, it also doesn’t strike me as a hardware problem. What else is there that could be causing these problems??

Could it be still some problem with your apps? As maybe you’ve installed the same apps on FPOOS, A6, 7 and LOS 17.1?
You might start the phone in #dic:safemode and try to use it then for a little bit - just to see if any of the problems (reboots, freezes, unresponsive, app crash) appear then?
You aren’t using the Facebook app, are you? At lease there had been reports of it creating problems…

1 Like

Dear Emmy,

I have similar issues with freezes and reboots. Luckily for me, the apps did not crash, but only freeze for several seconds. So waiting did help for me.
For the randomly and frequently rebooting, I figured out that the battery was losing contact to the phone. I assume it is build a bit too small such that a small hit or vibration at the phone makes it lose contact, which causes a reboot. Two strips of sticky tape at the bottom of the battery helped me to reduce my reboots. It is now down to once in a week for me.

Let me know if sticky tape works for you. And if you find a solution for the crashes, I would be intersted, as well!

Chris

2 Likes

I’ve got the exact same phone behaviour, it’s becoming unusable… Have you had any luck finding a root cause, fix or work around? I’m only just starting investigating, and will hold off factory resets or OS changes (I haven’t rooted my phone, yet!) since it didn’t seem to help you at all.

Hi!
I have similar problems with my Fairphone 2 (dated from January 16) and a friend who also has a Fairphone 2 (about 3 years old) has those problems as well.

  • Apps regularly crash, and it happens with different apps: whatsapp, spotify, camera…
  • The battery is suddenly getting emptied (for example it drops down from 50%to 10%, often under 20% it looses power super rapidly and it’s impossible to use the camera for a phone call because the battery empties itself within minutes).
  • The phone randomly reboots.
  • After the battery crashes, it can be very difficult to start the phone again. This can be particularly problematic! For example if you’re traveling and relying on your phone to have plane tickets, hotel bookings or contact informations.

I know very little about phones. I don’t know what TWRP is, FP Open or LineageOS, opening the phone in safe mode or rooting the phone. I don’t feel like I have time to spend to become a phone expert to use my phone, but I’m glad that this forum exists to get some help. My friend is even more helpless about her phone and I convinced her to give Fairphone a chance and first change some broken parts (camera and get a new battery) instead of buying a new phone. It’s a pity though, that the concept of having a long-lasting phone is failing because of technical problems… :roll_eyes:

I hope I can get some “simple” help here. If possible! In the meanwhile we’ll both order new batteries and hope that this can help the phones.

I think the best thing for you to have help would be contacting a #fairphoneangel, because you seem to have multiple problems. This would probably require opening the phone, and if tou don’t feel like it, it’s probably not a good idea, and he/she could help you more easily. I hope there is one in your vicinity.

PS. If you want to have an explanation about safe mode, recovery, and other “techie” things, you can check all the topics of the fairphone dictionary, marked by the #dictionary tag :wink:

2 Likes

I am afraid you are facing “bit rotting” on the buildin sdcard. In other words files on the sdcard are becoming corrupt.
You can check this by copying larger files to your sdcard and check their checksums from time to time.
If you have a linux laptop or know somebody who has one then this is very simple:

  1. prepare some files for the check. Size of all files in total about 1 GB I would say. - File type does not matter. Use e.g. large pdf files (e-papers) or jpegs with high resolution, very low compression .
  2. Generate checksums for these files on the linux system (use e.g. the md5sum or one of the sha…sum commands) and save them for later reference in a file.
  3. Copy these files to your fp2.
  4. Copy them back to the/a linux system from time to time and check their checksums again.
  5. If one or more has/have checksum changed then this is most likely your sdcard

An even simpler procedure might work, too. Copy files from a laptop to you phone - again about 1 GB in total - and copy them back to a laptop intermittently. The copy process back to the laptop might “complain” about files which could not be read/opened!

Reading about the problems you have I think that the new battery will at least help. So it’s a good idea you ordered one.
What also may help against the crashing apps is a #dic:factorydatareset. This is technically not difficult but you’ll loose all data on the phone. This means you should backup all important data before (photos, contacts, messages, …) and be prepared that it’s a bit time consuming to reinstall everything.

2 Likes

Ok! Thanks for your help alex21 and Volker!
I unfortunately don’t have a fairphoneangel close to me. I live in Sweden where fairphones are unfortunately not so popular yet. The closest one is in Copenhagen.
But I did order a new battery today and will keep reading on the forum the coming days/weeks to try to understand more about my phone and the possible solutions to take.
Yes, maybe a datareset at some point. A friend helped me install a backup app recently so I might be courageous and do it.

Hey Emmy,
I have the same problems and I am really frustrated. Did you find a solution?

Hello all,

I’ve been fighting my way through since May with LineageOS. For a while the phone was okayish, occasionally apps crashed but not constantly and so I tried to ignore the problem. At this point, though, the problems have gotten so bad that I’m very seriously considering buying a new phone.

My clock app crashes daily (I have a daily alarm set and I can never turn it off, always have to either restart the whole phone or wait a few minutes of it ringing till the OS informs me that the app has crashed and offers to close it.) I can’t answer phone calls anymore - the phone app shows that I am being called, but the screen won’t respond, so I can’t answer the call by moving the slider. Every video I try to take or watch crashes after about 10 seconds, the camera often takes forever to actually take a photo, etc. It’s just no fun anymore.

@mike_s: your idea of bit-rot sounds interesting. I haven’t gone through the steps you mention yet, though the last time I tried to access photos from my phone with my laptop it did indeed complain that it could not read/open the files. But before I try your steps, one question: if the checksums have changed and the problem is with the (internal or external?) sd card: would there be any solution to this problem? At this point, the phone is 4,5 years old and while I would have liked to make it to the 5-year mark, I think I can live with the idea of getting a new one soon. I certainly would not want to invest more money into this one at this stage, like buying a new replacement module or something like that, I don’t think that’s worth it anymore.

Now the big question is: do I buy the Fairphone 3+ or a different used phone? Support Fairphone’s mission, which I still think is very important - but buy a new phone, meaning more resources used, or do I buy a used phone from a different company, which doesn’t support systemic change but also doesn’t require new resources to be mined from the ground? Difficult question, though at the moment I’m leaning towards buying the FP3+.

Edit: P.S.: Just poked around the forum a bit and realized that apparently there is no Open OS or Lineage or /e/ available for FP3/FP3+ yet, right? That makes my decision harder again, as I don’t really want to go back to a Google phone… :-/

Fairphone 3: /e/ is available for months now, LineageOS is close to official (in LineageOS terms). Both are being actively used by users of this forum.

Fairphone 3+: /e/ is in the works, LineageOS … I don’t know.

3 Likes

The internal sd card is causing this issue, I think. It is my understanding, that the sd card is part of the base module and can not be replaced. So unfortunately your phone can’t be repaired.