Connecting Problem from FP4 with USB to Windows PC

Hello Duds,

Hello Duds,
I have a problem with my Fairphone 4. I wanted to connect my FP4 with my computer via USB to my Windows 11 computer. And for the first time it didn’t work and I still can’t get it to work.
I always get this error message:


I’ve already tried a few things:
used other USB-C cables, including the one my Quest 3 uses to transfer data from the PC. I have used 3 different PCs with different USB-C cables… it doesn’t work. I restarted the FP4 and removed the battery. Unfortunately nothing worked.
Does anyone have a tip for me?

THX :slight_smile: , have a nice sunny weekend!

Long shot:
Do you have USB Debugging enabled in the developer setting?

That“s no error message. What’s shown is the correct setting.

But did you switch to data transfer mode instead of just charging?

2 Likes

It IS an error message.
He attempts to switch “Choose the device controlling the USB connection”
from “This device” to “Connected device” and when he does the message “Switching not possible” pops up.

I assume you just want to establish an USB connection for file transfer. Ignore these two control options. Instead, scroll down to the option “data transfer” and choose that.

1 Like

Depends on what you call an ‚error message‘. It just tells you, that this option is not available at the moment. But anyway, it’s not relevant for the connection at all.

That’s the problem, it’s just not possible. It is displayed to me. “Change not possible / Wechseln nicht möglich” when I tap on “Connected device / Verbundenes Gerät”.

That doesn’t work because I have a device from the company. I have permissions to the developer settings

The lower functions are only USB tethering and MIDI. They even work. At least the Windows PC recognizes them. But I can’t get the other functions to work.

Then check your cable is a data cable or try another cable. You dont touch the upper part to transfer data.

As I already said, that’s not the problem, you are on the wrong path.

1 Like

Not a solution, but a possible workaround. I run Cx File Explorer on an FP3 to enable me to use Nemo on a PC running Linux Mint to transfer FP3 files to the PC. I have also used Nemo to transfer files from the PC to the FP3 and to delete files from the FP3. (The phone and PC both talk to the same router.) I haven’t tried using Cx File Explorer with my Windows laptop as I haven’t needed to. (I use Warpinator to transfer files between the Linux and Windows machines so I could always use the Linux machine as an intermediary if Cx File Explorer and Windows don’t play nicely.)

You are right:


Here is the whole picture. I do not have this option to choose from. I need to talk to my admin so that I can get into developer mode.

I have used several cables. I also have the cable from my Oculus Quest 3 that streams the data between the PC and VR glasses and that doesn’t work either. I very much doubt that it has anything to do with a cable.

If your phone is administered (maybe for work) then the file transfer option has probably been disabled through MDM. So you’ll need to talk to your admins to get that, but you don’t need Developer options, if that’s what you’re referring to.

If the PC is a work PC then check your permissions there, too. Just explain your complete use case to your admins.

3 Likes